Uva-548-Tree(二叉树与stream与dfs)

  Tree 

You are to determine the value of the leaf node in a given binary tree that is the terminal node of a path of least value from the root of the binary tree to any leaf. The value of a path is the sum of values of nodes along that path.

Input 

The input file will contain a description of the binary tree given as the inorder and postorder traversal sequences of that tree. Your program will read two line (until end of file) from the input file. The first line will contain the sequence of values associated with an inorder traversal of the tree and the second line will contain the sequence of values associated with a postorder traversal of the tree. All values will be different, greater than zero and less than 10000. You may assume that no binary tree will have more than 10000 nodes or less than 1 node. 

Output 

For each tree description you should output the value of the leaf node of a path of least value. In the case of multiple paths of least value you should pick the one with the least value on the terminal node.

Sample Input 

3 2 1 4 5 7 6
3 1 2 5 6 7 4
7 8 11 3 5 16 12 18
8 3 11 7 16 18 12 5
255
255

Sample Output 

1
3
255
 
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <string>
#include <sstream>

using namespace std;

#define BG 10005
int in_order[BG],post_order[BG];
int lrp[BG],rrp[BG];//use two queue to take the left and right child seperatly of the i point to show what the tree is look like.
int n;
bool input(int *order)
{
    string s;
    stringstream ss;//deivide and transform the string
    int i=1;
    n=0;
    if(getline(cin,s))
    {
        ss.str(s);
        while(!ss.fail())
        {
            ss>>order[i];
            i++;
            n++;
        }
        return true;
    }
    else
        return false;
}
int buildtree(int L1,int R1,int L2,int R2)//
{
    if(L1<=R1)
    {
        int root;
        root=post_order[R2];
        int p=1;
        while(in_order[p]!=root)p++;
        int ln;
        ln=p-L1;
        lrp[root]=buildtree(L1,p-1,L2,L2+ln-1);//the left child tree of the root in the in_order and the post_order(to find its root--the left child of the current root)
        rrp[root]=buildtree(p+1,R1,L2+ln,R2-1);
        return root;
    }
    else
        return 0;
}
int best_sum=100000000,res;
void dfs(int root,int csum)//csum help store the specific value of sum at that moment
{
    csum+=root;
    if(lrp[root]==0&&rrp[root]==0)//leaves
    {
        if(best_sum>csum||(best_sum==csum&&res>root))
        {
            res=root;
            best_sum=csum;
        }
    }
    else
    {
        if(lrp[root])dfs(lrp[root],csum);//to the deepest and once a time
        if(rrp[root])dfs(rrp[root],csum);
    }
    
}
int main()
{
    while(input(in_order))
    {
        int proot;
        best_sum=100000000;
        input(post_order);
        proot=buildtree(1,n-1,1,n-1);
        dfs(proot,0);
        printf("%d\n",res);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值