NYOJ_287 Radar

题目:

描述
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

 

输入
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros
输出
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
样例输入
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
样例输出
Case 1: 2
Case 2: 1

分析:

题意为,在一个坐标系中,x中代表海岸,x轴以上有n个点,代表着n个岛屿,在x轴上建雷达,一直雷达的覆盖范围为半径为d的圆,求在x轴上最少建多少个雷达,才能把全部的岛屿覆盖起来,如果不能覆盖,输出-1.

区间选点问题为  给定 n个闭区间,求在里面选择最少的点使得每个区间里面都包含至少一个点(一个点可以在不同的区间)。之前有讲过,不赘述。


代码:

#include<string.h>
#include<iostream>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<iomanip>
#include<ctime>
#include<cstdio>
#include<stack>
#include<map>
#include<queue>
#include<vector>
#include<cctype>
using namespace std;

#define ESP 1e-8
struct NODE
{
    double l,r;
}node[1900];

bool cmp(struct NODE a,struct NODE b)
{
    return a.r<b.r;
}

int main()
{
    int N;
    int R;
    int kcase=1;
    while(~scanf("%d%d",&N,&R) && N+R)
    {
        int ans=0;
        int flag=0;
        for(int i=0;i<N;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            if(y > R)
                flag=1;
            node[i].l = x - sqrt(R*R-y*y);
            node[i].r = x + sqrt(R*R-y*y);            
        }
        if(flag==1)
        {
            printf("Case %d: -1\n",kcase++);
            continue;
        }
        
        sort(node,node+N,cmp);
        for(int i=0;i<N;)
        {
            ans++;
            double temp = node[i].r;
            i++;
            while(node[i].l < temp && i<N)
            {
                i++;
            }            
        }    
        printf("Case %d: %d\n",kcase++,ans);
    }    
    return 0;
}





  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值