A1005 Spell It Right (20分)【C语言】

A1005 Spell It Right (20分)【C语言】

原题链接

题目描述:
Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

输入格式:
Each input file contains one test case. Each case occupies one line which contains an N (≤10 ​100​​ ).

输出格式:
For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

输入样例:

12345

输出样例:

one five

实现代码:

#include <stdio.h>
#include <string.h>
char eng[15][15]={"zero", "one", "two", "three", "four", "five", "six", "seven", "eight", "nine"};

int main()
{
	int sum, i, digit[10], len=0;
	char str[110];
	gets(str);
	for(i=0; str[i]!='\0'; ++i){
		sum = sum + (str[i]-'0');
	}
	if(sum==0) printf("%s", eng[0]);
	else{
		while(sum){
			digit[len++] = sum % 10;
			sum /= 10;
		}
		printf("%s", eng[digit[len-1]]);
		for(i=len-2; i>=0; --i){
			printf(" %s", eng[digit[i]]);
		}
	}
	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值