A1071 Speech Patterns (25分)【C语言】

A1071 Speech Patterns (25分)【C语言】

原题链接

题目描述:
People often have a preference among synonyms of the same word. For example, some may prefer “the police”, while others may prefer “the cops”. Analyzing such patterns can help to narrow down a speaker’s identity, which is useful when validating, for example, whether it’s still the same person behind an online avatar.

Now given a paragraph of text sampled from someone’s speech, can you find the person’s most commonly used word?

输入格式:
Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return \n. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

输出格式:
For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a “word” is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

输入样例:

Can1: “Can a can can a can? It can!”

输出样例:

can 5

实现代码:

#include <iostream>
#include <string>
#include <map>
using namespace std;

bool check(char c){ //检查是否为有效字符 
	if(c>='0' && c<='9') return true;
	if(c>='a' && c<='z') return true;
	if(c>='A' && c<='Z') return true;
	return false;
}

int main()
{
	map<string, int> count; //计数字符串出现的次数 
	string str;
	getline(cin, str);
	int i=0;
	while(i<str.length()){
		string word;
		while(i<str.length() && check(str[i])==true){ //如果是有效字符 
			if(str[i]>='A' && str[i]<='Z'){
				str[i] += 32; //大写字母转为小写字母 
			}
			word += str[i]; //只要还是有效字符就添加到Word的后面 
			i++;  
		}
		if(word!=""){ //Word不为空时 
			if(count.find(word) == count.end()) count[word] = 1; //如果不能找到Word,就初始化为1 
			else count[word]++; //能找到,计数加1 
		}
		while(i<str.length() && check(str[i])==false) i++; //如果不是有效字符,则跳过 
	}
	string ans;
	int max = 0;
	for(map<string, int>::iterator it=count.begin(); it!=count.end(); ++it){
		if(it->second > max){
			max = it->second;
			ans = it->first;
		}
	}
	cout<<ans<<" "<<max<<endl;
	
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值