Doing Homework again 贪心算法

问题:

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

输入:

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.

输出:

For each test case, you should output the smallest total reduced score, one line per test case.

样例输入:

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

样例输出:

0
3
5

很简单的一个贪心算法,从价值最大的作业开始安排

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int v[10000];
struct work
{
    int va;
    int day;
};
bool cmp(work a,work b)
{
    return a.va>b.va;
}
int so(int a)                         ///对不同的天数进行访问
{
    if(a==0)                         ///当天数为零时,无法安排,只能舍弃
    {
        return 1;
    }
    else if(v[a]==0)                ///当找到某一天空闲时,将作业安排上,并标记访问
    {
        v[a]=1;
        return 0;
    }
    else if(v[a]==1)              ///如果当前天数被访问,那么继续向前找
    {
        so(a-1);
    }
}
int main()
{
    int n;
    scanf("%d",&n);
    while(n--)
    {
        int m;
        scanf("%d",&m);
        work ss[m];
        for(int i=0;i<=m;i++)
        {
            v[i]=0;
        }
        for(int i=0;i<m;i++)
        {
            scanf("%d",&ss[i].day);
        }
        for(int i=0;i<m;i++)
        {
            scanf("%d",&ss[i].va);
        }
        sort(ss,ss+m,cmp);
        int sum=0;
        for(int j=0;j<m;j++)
        {
            if(so(ss[j].day))
            {
                sum=sum+ss[j].va;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值