1789 Doing Homework again 倒叙思想的贪心算法

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    

Memory Limit: 32768/32768 K (Java/Others)
 

Problem Description

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.   Input The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 Output For each test case, you should output the smallest total reduced score, one line per test case.
  Sample Input

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

  Sample Output

0
3
5
#include "iostream"
#include <algorithm>
#include <cstring>
using namespace std;

struct Node{
int time,fen;
}node[1005];


int cmp(struct Node a,struct Node b){
if(a.fen!=b.fen)
return a.fen>b.fen;//分数越高排名越前
return a.time<b.time;//分数相同是ddl越早排名越前
// ddl=deadline,截止日期
}



int visit[2010];//visit表示当天是否写过作业,如果当天没写过,值为0,否则为1
int main(){


freopen("/Users/qigelaodadehongxiaodi/Desktop/data1.txt", "r", stdin);
//这个不理,是用来方便输入输出的东西,利用文本输入流来读取数据
//提交代码的时候记得注销这条语句

int m;
cin>>m;
while(m--){

int n,i,j,ans=0;
memset(visit, 0, sizeof(visit));//visit表示当天是否写过作业,
cin>>n;
for(i=0;i<n;i++){
cin>>node[i].time;
}
for(i=0;i<n;i++){
cin>>node[i].fen;
}

sort(node,node+n,cmp);

for(i=0;i<n;i++){

j=node[i].time;
//从截止日期往前推,如果其中有一天没有用过,则这一天做第i份作业
//比如j=4,则从第四天开始往前推,找到四天中最晚的空的时间,拿来做这份作业,因此可以在完成作业的基础上,在前面留下更多的位置给ddl早的作业
//这种倒着的思想很重要!
while(j){
if(!visit[j]){//即最晚的空的时间第j天可以拿来完成第i天的作业
visit[j]=1;//表示用过了
break;
}
j--;
}

if(j==0)//如果j=0,表明从ddl往前的每一天都被占用了
//没有时间给他使用,这门课完不成
//完不成的原因是因为其性价比太低,最后才选择做,然后没办法爆炸了
ans+=node[i].fen;
}
cout<<ans<<endl;

}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

苦茶子12138

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值