POJ 1860 Currency Exchange 解题思路

Currency Exchange
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 23989 Accepted: 8701

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4.

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES


题目大意:在这个城市里有N种货币,M个货币兑换点,Nick所持有的货币种类是S,数目是V,后面输入M行,代表在每个兑换点的兑换情况,每行有6个数据:货币x,货币y,这个站点货币x到货币y的兑换率,本站点货币x到货币y所要收取的佣金
本站点货币y到货币x的汇率,以及在本站点货币y兑换到货币x要收取的佣金。题目问能否通过某种兑换策略使自己的财产增加,如果能则输出YES,否则输出NO

解题思路:不管Nick所拥有哪种货币,到最后还是要兑换到原来的货币种类来比较,这就会形成一个环状,该题目就是考察是否存在正权环

代码如下:
#include <iostream>
#include<string.h>
#include<stdio.h>
#include<queue>
using namespace std;
struct node
{
    int vis;
    double rate;
    double yongjin;
} map[110][110];          //用结构体存储个人认为比较方便
int m,n,s,i;
double v,fortune[110];
int x,y;
int spfa(int s)
{
    queue<int>q;
    int vis1[110];
    memset(vis1,0,sizeof(vis1));
    fortune[s]=v;
    q.push(s);
    vis1[s]=1;
    while(!q.empty())
    {
        int x=q.front();
        q.pop();
        vis1[x]=0;                        //这里在取出队列的头数据后要把vis1[x]变成0,以为后面兑换回来时还要用到x
        for(i=1; i<=n; i++)
        {
            if(map[x][i].vis==1&&fortune[i]<(fortune[x]-map[x][i].yongjin)*map[x][i].rate)  //货币x与i之间要能够进行兑换且兑换之后财产会增加
            {
                fortune[i]=(fortune[x]-map[x][i].yongjin)*map[x][i].rate;
                if(fortune[s]>v) return 1;
                if(vis1[i]==0)
                {
                    vis1[i]=1;
                    q.push(i);
                }
            }
        }
    }
    return 0;
}
int main()
{
    scanf("%d %d %d %lf",&n,&m,&s,&v);
    for(i=0; i<m; i++)
    {
        scanf("%d %d",&x,&y);
        scanf("%lf %lf",&map[x][y].rate,&map[x][y].yongjin);
        scanf("%lf %lf",&map[y][x].rate,&map[y][x].yongjin);
        map[x][y].vis=map[y][x].vis=1;       //做下标记,表示x与y之间可以进行兑换
    }
    if(spfa(s)) printf("YES\n");
    else printf("NO\n");
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值