poj3009Curling 2.0 题解

Curling 2.0 Time Limit:1000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u
Appoint description:

Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.


Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

  • At the beginning, the stone stands still at the start square.
  • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
  • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
  • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
    • The stone hits a block (Fig. 2(b), (c)).
      • The stone stops at the square next to the block it hit.
      • The block disappears.
    • The stone gets out of the board.
      • The game ends in failure.
    • The stone reaches the goal square.
      • The stone stops there and the game ends in success.
  • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.


Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).


Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board
First row of the board

...
h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0vacant square
1block
2start position
3goal position

The dataset for Fig. D-1 is as follows:

6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input

2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0

Sample Output

1
4
-1
4
10
-1


题目大意:给定的一个map,其中1代表障碍,0代表无障碍,2代表起点,3是终点; 每次移动时只能向临近一格不是障碍的方向走,如果在一个方向上没有障碍那么可以一直走,,如果遇到障碍物,此时障碍物会消失,如果行动时超出方格的界限或行动次数超过了10则会结束,,如果移动时经过3则会成功,记下此时行动次数(不是行动的方格数),求最小的行动次数。。思路其实就是深搜,只是这里每次可以移动多个方格,而且遇到障碍时障碍会消失。


代码:

#include <iostream>
#include<string.h>
using namespace std;
int map[110][110];
int fx[]= {-1,0,1,0};
int fy[]= {0,-1,0,1};
int sx,sy,ex,ey;
int m,n;
int minn;
void dfs(int x,int y,int step)
{
    int i;
    if(step>10) return;
    for(i=0;i<4;i++)
    {
       int xx=x+fx[i];
       int yy=y+fy[i];
       int nx=x;
       int ny=y;
       while(xx>=0&&xx<n&&yy>=0&&yy<m&&map[xx][yy]!=1)
       {
          nx+=fx[i];
          ny+=fy[i];
          if(nx==ex&&ny==ey)
          {
              if(minn>step) minn=step;
              return;
          }
          xx=nx+fx[i];
          yy=ny+fy[i];
          if(xx<0||xx>=n||yy<0||yy>=m) break;
          if(map[xx][yy]==1)
          {
              map[xx][yy]=0;
              dfs(nx,ny,step+1);
              map[xx][yy]=1;
          }
       }
    }
}
int main()
{
    int i,j;
    while(cin>>m>>n&&(m+n))
    {
        minn=9999;
        for(i=0; i<n; i++)
        {
            for(j=0; j<m; j++)
            {
                cin>>map[i][j];
                if(map[i][j]==2)
                {
                    sx=i;
                    sy=j;
                }
                if(map[i][j]==3)
                {
                    ex=i;
                    ey=j;
                }
            }
        }
        dfs(sx,sy,0);
        if(minn<10)
            cout<<minn+1<<endl;
        else cout<<"-1"<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值