二叉树 题解

数据结构实验之二叉树的建立与遍历

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

       已知一个按先序序列输入的字符序列,如abc,,de,g,,f,,,(其中逗号表示空节点)。请建立二叉树并按中序和后序方式遍历二叉树,最后求出叶子节点个数和二叉树深度。

输入

 输入一个长度小于50个字符的字符串。

输出

输出共有4行:
第1行输出中序遍历序列;
第2行输出后序遍历序列;
第3行输出叶子节点个数;
第4行输出二叉树深度。

示例输入

abc,,de,g,,f,,,

示例输出

cbegdfacgefdba35


心得:一道不错的题目,不难但考察了不少二叉树的知识。。

代码:

#include <iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
using namespace std;
struct node
{
    char data;
    struct node *l,*r;
};
struct node *create(struct node *p)
{
    char c;
    cin>>c;
    if(c==',')p=NULL;
    else
    {
        p=(struct node *)malloc(sizeof(struct node));
        p->data=c;
        p->l=create(p->l);
        p->r=create(p->r);
    }
    return p;
};
void inorder(struct node *p)
{
    if(p)
    {
        inorder(p->l);
        cout<<p->data;
        inorder(p->r);
    }
}
void lastorder(struct node *p)
{
    if(p)
    {
        lastorder(p->l);
        lastorder(p->r);
        cout<<p->data;
    }
}
int num=0;
void yezi(struct node *p)
{
    if(p)
    {
        if(p->l==NULL&&p->r==NULL)
            num++;
        else
        {
            yezi(p->l);
            yezi(p->r);
        }
    }
}
int deep(struct node *p)
{
    int ld=0,rd=0;
    if(p==NULL) return 0;
    else
    {
        ld=deep(p->l);
        rd=deep(p->r);
        if(ld>rd) return ld+1;
        else return rd+1;
    }
}
int main()
{
    struct node *p;
    p=create(p);
    inorder(p);
    cout<<endl;
    lastorder(p);
    cout<<endl;
    yezi(p);
    cout<<num<<endl;
    int depth=deep(p);
    cout << depth<< endl;
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值