poj 2187Beauty Contest(凸包)

Beauty Contest
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 35138 Accepted: 10894

Description

Bessie, Farmer John's prize cow, has just won first place in a bovine beauty contest, earning the title 'Miss Cow World'. As a result, Bessie will make a tour of N (2 <= N <= 50,000) farms around the world in order to spread goodwill between farmers and their cows. For simplicity, the world will be represented as a two-dimensional plane, where each farm is located at a pair of integer coordinates (x,y), each having a value in the range -10,000 ... 10,000. No two farms share the same pair of coordinates.

Even though Bessie travels directly in a straight line between pairs of farms, the distance between some farms can be quite large, so she wants to bring a suitcase full of hay with her so she has enough food to eat on each leg of her journey. Since Bessie refills her suitcase at every farm she visits, she wants to determine the maximum possible distance she might need to travel so she knows the size of suitcase she must bring.Help Bessie by computing the maximum distance among all pairs of farms.

Input

* Line 1: A single integer, N

* Lines 2..N+1: Two space-separated integers x and y specifying coordinate of each farm

Output

* Line 1: A single integer that is the squared distance between the pair of farms that are farthest apart from each other.

Sample Input

4
0 0
0 1
1 1
1 0

Sample Output

2
 /*
9
1 2
2 2
0 1
1 1
2 1
3 1
0 0
1 0
2 0

10
*/
#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
int n,top;
struct point
{
    int x,y;
}pt[51000],Stack[51000],pointa;
int cross(point a,point b,point c)
{
    return (b.x-a.x)*(c.y-a.y)-(b.y-a.y)*(c.x-a.x);
}
int cmp(point a,point b)
{
    if(a.y==b.y)
        return a.x<b.x;
      return a.y<b.y;
}

int cmp1(point a,point b)
{
    double k = cross(pointa,a,b);
    if(k>0) return 1;
    if(k<0) return 0;
    return pow(a.x-pointa.x,2)+pow(a.y-pointa.y,2)>pow(b.x-pointa.x,2) + pow(b.y-pointa.y,2);//当共线时候,距离按照从大到小排时
                                                                                             //下文cross()<=0;
                                                                                             //当从小到大排时cross()<0;
}                                                                                            //注意   从大到小排序  共线时只记录远的不记录近的,从小到大排都记录
void gram()
{
    sort(pt,pt+n,cmp);
    pointa = pt[0];
    pt[n] = pt[0];
    sort(pt+1,pt+n,cmp1);
    int i;
    top=2;
    Stack[0]=pt[0];
    Stack[1]=pt[1];
    Stack[2]=pt[2];
    for(i=3;i<=n;i++)
    {
        while(top>=2&&cross(Stack[top-1],Stack[top],pt[i])<=0)//如果是<=0那么极角排序时当共线时距离从大到小排
            top--;                                            //如果<0那么极角排序时当共线时距离从小到大排
        Stack[++top] = pt[i];
    }
}
int main()
{
    int i,j;
    while(~scanf("%d",&n))
    {
        for(i=0;i<n;i++)
            scanf("%d%d",&pt[i].x,&pt[i].y);
        gram();
        int max = 0;

             for(i=0;i<=top;i++)
            {
                for(j=0;j<=top;j++)
                {
                    if(max < pow( Stack[i].x-Stack[j].x,2 ) + pow( Stack[i].y-Stack[j].y,2 ) )
                        max = pow(Stack[i].x-Stack[j].x,2)+pow(Stack[i].y-Stack[j].y,2);
                }
            }
            printf("%d\n",max);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值