Just a Hook(线段树 区间更新)

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 29771    Accepted Submission(s): 14696


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

Sample Input
  
  
1 10 2 1 5 2 5 9 3
 

Sample Output
  
  
Case 1: The total value of the hook is 24.
 

Source
成段更新: 需要用到延迟标记 ( 或者说懒惰标记 ), 简单来说就是每次更新的时候不要更新到底 , 用延迟标记使得更新延迟到下次需要更新 or 询问到的时候。

线段树功能 :update: 成段替换  ( 由于只 query 一次总区间 , 所以可以直接输出 1 结点的信息 )
#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;

#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
const int maxn=100002;
int col[maxn<<2];//用来标记每个节点,为0则表示没有标记,否则为标记,以颜色的价值作为标记。
int sum[maxn<<2];//求和

void PushUp(int rt)//向上更新和
{
	sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}

void PushDown(int rt,int m)//对某一个区间进行改变,如果被标记了,在查询的时候就得把改变传给子节点,因为查询的并不一定是当前区间
{//m为区间长度
	if(col[rt])//已经标记过,该区间被改变过
	{
		col[rt<<1]=col[rt<<1|1]=col[rt];//标记子节点
		sum[rt<<1]=(m-(m>>1))*col[rt];//更新左儿子的和
		sum[rt<<1|1]=(m>>1)*col[rt];//更新右儿子的和
		col[rt]=0;
	}
}

void build(int l,int r,int rt)
{
	col[rt]=0;//初始化为所有节点均未标记
	sum[rt]=1;//初始值为1
	if(l==r)
		return;
	int m=(l+r)>>1;
	build(lson);
	build(rson);
}

void update(int L,int R,int c,int l,int r,int rt)
{
	if(L<=l&&r<=R)
	{
		col[rt]=c;
		sum[rt]=c*(r-l+1);//更新代表某个区间的节点和,该节点不一定是叶子节点
		return ;
	}
	PushDown(rt,r-l+1);//向下传递
	int m=(l+r)>>1;
	if(L<=m)
		update(L,R,c,lson);//更新左儿子
	if(R>m)
		update(L,R,c,rson);//更新右儿子
	PushUp(rt);//向上传递更新和
}
int main()
{
	int k;cin>>k;
	int n,c,add,a,b;
	for(int i=1;i<=k;i++)
	{
		scanf("%d",&n);
		build(1,n,1);
		scanf("%d",&c);
		for(int j=1;j<=c;j++)
		{
			scanf("%d%d%d",&a,&b,&add);
			update(a,b,add,1,n,1);
		}
		printf("Case %d: The total value of the hook is %d.\n",i,sum[1]);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值