1059. Prime Factors (25)

1059. Prime Factors (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
HE, Qinming

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1^k1* p2^k2 *…*pm^km.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p1^k1 * p2^k2 *…*pm^km, where pi's are prime factors of N in increasing order, and the exponent ki is the number of pi -- hence when there is only one pi, ki is 1 and must NOT be printed out.

Sample Input:
97532468
Sample Output:
97532468=2^2*11*17*101*1291
#include <iostream>
#include <cstdio>
#include <cmath>
#include<cstring>
int prime[10001];
int cnt = 0;
using namespace std;
void findprime(int n)
{

  for( int i = 2; i <= n; i++)
  {
      int flag = 0;
     for(int j = 2; j <= sqrt(i); j++)
     {
         if( i % j == 0)
         {
             flag = 1;
             break;
         }

     }
     if(flag == 0)
         {
             prime[cnt++] = i;
         }
  }
}
int main()
{
  findprime(10000);
  int a[10001];
  long n;
  cin>>n;
  if(n == 1)
  {
      cout<<"1=1"<<endl;
      return 0;
  }
  long tmp = n;
  memset(a,0,sizeof(a));
  for(int i = cnt - 1; i >= 0; i--)
  {
      if(n%prime[i]==0)
      {
          while(1)
          {
             a[prime[i]]++;
             n /= prime[i];
             if( n % prime[i] != 0)
                break;
          }
      }
  }
  cout<<tmp<<"=";
  int flag = 0;
  for(int  i = 2; i <= 10000; i++)
  {
      if(a[i] != 0)
      {
          if(flag == 0)
          {
             printf("%d",i);
             flag = 1;
          }

           else
           printf("*%d",i);

        if(a[i]!=1)
        {
            printf("^%d",a[i]);
        }
      }

  }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值