D - Sorting It All Out POJ - 1094 (拓扑排序)

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 
Sorted sequence cannot be determined. 
Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence. 

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0
 

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

题意: 

这个题就是让判断给出的字母的顺序,如果给出的关系中判断出存在环(回路),比如A<B,B<A。那么输出“Inconsistency found after x  relations.”即在第x个关系之后判断出来存在环;如果给出的关系都无法判断字母的次序,那么就输出“Sorted sequence cannot be determined.”;如果在第x个关系之后就找出了字母的次序,那么就输出“Sorted sequence determined after x relations: (字母的次序).”。

所以每次输入一个关系就要去进行一次拓扑排序,来判断是否有结果。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<stdlib.h>
#define maxn 36
int path[maxn][maxn];  //例 A<B 即A->B 用此数组来记录 
int res[maxn];  //记录最终的字母次序 
int rudu[maxn];   //每个点的入度
int changedu[maxn];
char str[8];
int n,m; 

int tuopo()
{
	for(int i=0;i<n;i++)
	 changedu[i]=rudu[i];   
//因为每输入一个关系都要判断一次是否有结果,所以changedu这个数组是来看每个点度的变化
	
	int cnt,k,count=0,flag=1;
	for(int i=0;i<n;i++)
	{
		cnt=0;
		for(int j=0;j<n;j++)
		{
		   if(changedu[j]==0)
		   {
			  cnt++;   //记录有多少度为0的结点 
			  k=j;
		   }
		}
		if(cnt==0)return -1; //没有度为0的结点,那么肯定存在环,无法判断顺序。
		else if(cnt>1)flag=0;//现在为止存在多个度为0的点,次序暂时不能判断,要继续输入关系。
		changedu[k]--;    
		res[count++]=k;  //将度为0的点存入数组中
		for(int j=0;j<n;j++)
		{
		   if(path[k][j]==1)  //将以这个点为起点的终点的入度-1 
			 changedu[j]--;
		} 
		 
	}
	if(flag)return 1; //flag=1说明每次都只有一个度为0的点,已经可以判断次序了
	return 0; 
	
}

void func()
{
	int ok=1;
	for(int i=0;i<m;i++)
    {
     	scanf("%s",str);
     	if(ok)  //ok为0时,说明已经会产生结果了,就不必再进行下面的操作了 
     	{
     		if(path[str[0]-'A'][str[2]-'A']==0)
	     	{
	     	   path[str[0]-'A'][str[2]-'A']=1;
	     	   rudu[str[2]-'A']++;
			}
	     	int result=tuopo();
	     	if(result==1)
			{
			   printf("Sorted sequence determined after %d relations: ",i+1);
			   for(int j=0;j<n;j++)
				 printf("%c",char(res[j]+'A'));
			   printf(".\n");
			   ok=0;// 已经有结果了,接下来的关系可以不去进行拓扑排序再判断了 
			} 
			else if(result==-1)
			{
			   printf("Inconsistency found after %d relations.\n",i+1);
			   ok=0; //已经产生结果了,可以不必再判断了 
			} 
		}
     	
	}
	//ok为1,说明上面的关系都没有产生结果 
	if(ok) printf("Sorted sequence cannot be determined.\n"); 
} 

int main()
{
	while(scanf("%d%d",&n,&m)!=EOF&&(n+m)!=0)
	{
		if(m<n-1)  //关系太少,无法确定次序 
		{
		   for(int i=0;i<m;i++)
			 scanf("%s",str);
		   printf("Sorted sequence cannot be determined.\n"); 
		}
		else
		{
		   memset(path,0,sizeof(path));
		   memset(rudu,0,sizeof(rudu));
		   func(); 
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值