Sorting It All Out POJ - 1094 +拓扑排序

问题:

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 
Sorted sequence cannot be determined. 
Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence. 

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

题意:对于每次输入一个关系,就对输入进行一次拓扑排序,拓扑排序的结果有三种情况。
第一种:如果第n个关系出现了环,直接输出结果即可,一旦结果确定,以后的输入就不用判断了。
第二种:如果第n个关系刚好等于n,并且序列里相邻的节点已经明确出现了<,关系,说明大小关系已经确定了,如果不明确还需要继续看以后的输入才行。
第三种:所有关系全用完,节点数目刚好等于n,但是序列里的节点还未明确出现<关系。

思路:拓扑排序加一些剪枝,只要确定结果就直接输出不在往下判断。

代码:

#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
int u[2100],v[2100],first[2100],in[2100],du[2100],next[2100];
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m)&&(n||m))
    {
        memset(first,-1,sizeof(first));
        memset(in,0,sizeof(in));
        char s[5],h[30];
        for(int i=1; i<=m; i++)
        {
            scanf("%s",s);
            u[i]=s[0]-'A';
            v[i]=s[2]-'A';
        }
        int Y=0,N=0;
        for(int i=1; i<=m&&Y==0&&N==0; i++)
        {
            memset(du,0,sizeof(du));
            next[i]=first[u[i]];
            first[u[i]]=i;
            in[v[i]]++;
            queue<int>q;
            for(int j=0; j<n; j++)
            {
                du[j]=in[j];
                if(du[j]==0)
                    q.push(j);
            }
            int tag=1,t=0;
            while(!q.empty())
            {
                if(q.size()>1)
                    tag=0;
                int k=q.front();
                q.pop();
                h[t++]=k+65;
                for(int j=first[k]; j!=-1; j=next[j])
                {
                    du[v[j]]--;
                    if(du[v[j]]==0)
                        q.push(v[j]);
                }
            }
            h[t]='\0';
            if(t==n&&tag==1)
                Y=i;
            else if(t<n)
                N=i;
        }
        if(Y==0&&N==0)
            printf("Sorted sequence cannot be determined.\n");
        if(Y==0&&N!=0)
            printf("Inconsistency found after %d relations.\n",N);
        if(Y!=0&&N==0)
            printf("Sorted sequence determined after %d relations: %s.\n",Y,h);
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值