Dividing HDU - 1059 ( 多重背包 - 二进制简化 )

Dividing

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. 
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles. 

Input

Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000. 

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line. 

Output

For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''. 

Output a blank line after each test case. 

Sample Input

1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0

Sample Output

Collection #1:
Can't be divided.

Collection #2:
Can be divided.

题意:

一共有6种钱,每种钱价值就是1,2,3,4,5,6;每个样例都给出6个数,这6个数就是每种钱的数量。

然后问是否能将给出的这些钱平分两份。

这就是多重背包的问题。

和HDU-1171特别相似,也是平分问题。https://blog.csdn.net/SEVENY_/article/details/81603813

代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
int money[1000009];  //二进制简化之后的钱的种类 
int dp[1000009];
int main()
{
	int k=0; //第k个样例 
	while(true)
	{ 
	        k++;
		int sum=0,t,ind=0; //sum钱的总数。t每种钱的数量。money数组的下标。
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=6;i++)
		{
			scanf("%d",&t);  
			sum+=t*i;
			for(int j=1;t!=0;j*=2) //二进制简化 
			{
				if(j<=t)
				{
					money[ind++]=i*j;
					t-=j;
				}
				else
				{
					money[ind++]=i*t;
					t=0;
				}
			}
		}
		if(sum==0)break; //钱总数为0就结束 
		printf("Collection #%d:\n",k);
		if(sum%2!=0)  //钱为奇数绝对没法平分 
		{ 
		    printf("Can't be divided.\n\n"); 
		}
		else
		{
			sum/=2;
			for(int i=0;i<ind;i++)
			{
				for(int j=sum;j>=money[i];j--)
				{
					dp[j]=max(dp[j],dp[j-money[i]]+money[i]);
				} 
			}
			if(dp[sum]==sum)printf("Can be divided.\n\n");
			else  printf("Can't be divided.\n\n"); 
		} 
	}
	return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值