POJ1014-HDU1059-Dividing-二进制优化的多重背包

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input

Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, …, n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line “1 0 1 2 0 0”. The maximum total number of marbles will be 20000.

The last line of the input file will be “0 0 0 0 0 0”; do not process this line.

Output

For each colletcion, output “Collection #k:”, where k is the number of the test case, and then either “Can be divided.” or “Can’t be divided.”.

Output a blank line after each test case.

Sample Input

1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0

Sample Output

Collection #1:
Can't be divided.

Collection #2:
Can be divided.

题目大意:

有六种弹珠,价值分别是1、2、3、4、5、6,给定每种弹珠的数量,问能否分成价值相等的两份。

核心思想:

多重背包,如果可以分出价值为i的弹珠组合,则dp[i]=1,否则dp[i]=0。
由于数据很大,需要用二进制优化
对于某种弹珠:
分别取用数量1、2、4、8、……、剩余数量,根据二进制特点,这样分组可以组合出任意数量。和遍历相比,这样会节省大量时间。

代码如下:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
typedef long long ll;
int a[8];
bool dp[60040];
int main()
{
	int ca=0;
	while(1)
	{
		int flag=0,sum=0;
		for(int i=1;i<7;i++)
		{
			scanf("%d",&a[i]);
			sum+=i*a[i];
			if(a[i])
				flag=1;
		}
		if(!flag)
			break;
		if(sum%2!=0)
		{
			printf("Collection #%d:\n",++ca);
			printf("Can't be divided.\n\n");
			continue;
		}
		sum>>=1;//只处理一份 
		memset(dp,0,sizeof(dp));
		dp[0]=1;
		for(int i=1;i<7;i++)
		{
			//此处二进制优化
			for(int j=1;j<=a[i];j<<=1)//j增大是通过移位操作实现的,相当于乘2 
			{
				for(int z=sum;z>=j*i;z--)
					if(dp[z-j*i])
						dp[z]=1;
				a[i]-=j;//j已经被使用 
			}
			if(a[i])//处理剩余的 
				for(int z=sum;z>=a[i]*i;z--)
					if(dp[z-a[i]*i])
						dp[z]=1;
		}
		printf("Collection #%d:\n",++ca);
		if(dp[sum])
			printf("Can be divided.\n\n");
		else
			printf("Can't be divided.\n\n");	
	}
	return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值