Strategy Game(模拟)

Strategy Game(模拟)

题目描述

A strategy game with J players is played around a table. Players are identified by numbers from 1 to J and will play a total of R rounds.
At each round each player will play once, in the order of their identifiers; that is, player 1 will play first, player 2 will play second, and so on. Once player J plays, the round is complete, and a next round starts.
A player earns a certain amount of Victory Points every time she or he plays. After all rounds are finished the total points of each player is computed as the sum of Victory Points the player earned on
each round. The winner is the player with the maximum number of points; in case of a tie the winner is the player who earned the maximum number of points and played last.
Given the number of players, the number of rounds and a list describing the Victory Points in the order they were obtained, you must determine which player is the winner.

输入

The input contains several test cases. In each test case, the first line contains two integers J and R,respectively the number of players and the number turns (1 ≤ J, R ≤ 500). The second line contains
J ∗ R integers, representing the Victory Points earned by each player in each turn, in the order they happened. The Victory Points obtained in each turn will be always integer numbers between 0 and 100, inclusive.

输出

For each test case in the input, your program must produce one single line, containing the integer representing the winner.

样例输入 

3 3
1 1 1 1 2 2 2 3 3
2 3
0 0 1 0 2 0

样例输出 

3
1

思路:入门题,比赛时看到是英文题就没注意,后来快结束的时候读了一下题,早知道就先开这道...附上AC代码

#include<bits/stdc++.h>
using namespace std;

int main()
{
	int j = 0; int r = 0;
	
	while(cin >> j >> r)
	{
		vector<int> score(j, 0);
		for(int k = 0; k < r; ++k)
		{
			for(int i = 0; i < j; ++i)
			{
				int temp = 0;
				cin >> temp;
				score[i] += temp;
			}
		}
		
		int max = 0;
		int winner = 0;
		
		for(int i = 0; i < j; ++i)
		{
			if(score[i] >= max)
			{
				max = score[i];
				winner = i + 1;
			}
		}
	
		cout << winner << endl;
	}
	
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
以下是一个简单的Python代码示例,演示了如何使用蒙特卡罗模拟实现近似动态规划。 假设我们要解决赌场游戏的问题:有一个6面的骰子,每次投掷后可以选择停止或继续投掷。如果在某次投掷中出现了1,则整个游戏结束,并失去所有赌注。如果在某次投掷中出现了2到6,则可以选择继续投掷或停止,每次继续投掷将会获得相应的奖金,但同时也有一定概率失去所有赌注。我们的目标是找到一个最优的策略,以最大化我们在游戏中获得的奖金。 我们可以使用蒙特卡罗模拟模拟游戏过程,并使用动态规划来学习最优策略。具体而言,我们可以使用一个价值函数来表示每个状态的价值,然后使用贝尔曼方程来更新这些价值。在每次模拟中,我们可以使用贪心策略来选择下一步的行动,并根据游戏结果来更新状态的价值。 下面是代码示例: ```python import random # 定义游戏规则 def roll_dice(): return random.randint(1, 6) def play_game(strategy): money = 10 while True: roll = roll_dice() if roll == 1: return 0 elif roll >= 2 and roll <= 6: if strategy(money, roll): money += roll else: return money else: raise ValueError("Invalid roll: {}".format(roll)) # 定义策略 def stop_strategy(money, roll): return True def greedy_strategy(money, roll): return roll > 2 # 使用蒙特卡罗模拟来更新状态价值 def update_value(strategy, values, n_simulations): for i in range(n_simulations): state = 10 while True: roll = roll_dice() if roll == 1: values[state] += strategy(state, roll) * (-state) break elif roll >= 2 and roll <= 6: if strategy(state, roll): state += roll else: values[state] += (1 - strategy(state, roll)) * state break # 使用动态规划来学习最优策略 def learn_strategy(values): optimal_strategy = [False] * 11 for state in range(1, 11): max_value = 0 for roll in range(2, 7): value = roll + values[min(state + roll, 10)] if value > max_value: max_value = value optimal_strategy[state] = True values[state] = max_value return optimal_strategy # 测试代码 values = [0] * 11 for i in range(100): update_value(greedy_strategy, values, 1000) optimal_strategy = learn_strategy(values) print("Optimal strategy:", optimal_strategy) ``` 在上面的代码中,我们定义了两个策略:stop_strategy 表示在任何情况下都停止投掷骰子,greedy_strategy 表示只有在骰子点数大于2时才继续投掷。然后我们使用蒙特卡罗模拟来更新每个状态的价值,并使用动态规划来学习最优策略。最后我们输出了学习到的最优策略。 需要注意的是,这只是一个简单的示例,实际应用中可能需要更复杂的模型和算法来解决更具挑战性的问题。
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值