Fence

Description

A team of k (1 <= K <= 100) workers should paint a fence which contains N (1 <= N <= 16 000) planks numbered from 1 to N from left to right. Each worker i (1 <= i <= K) should sit in front of the plank Si and he may paint only a compact interval (this means that the planks from the interval should be consecutive). This interval should contain the Si plank. Also a worker should not paint more than Li planks and for each painted plank he should receive Pi $ (1 <= Pi <= 10 000). A plank should be painted by no more than one worker. All the numbers Si should be distinct.

Being the team’s leader you want to determine for each worker the interval that he should paint, knowing that the total income should be maximal. The total income represents the sum of the workers personal income.

Write a program that determines the total maximal income obtained by the K workers.

Input

The input contains:

Input

N K
L1 P1 S1
L2 P2 S2

LK PK SK

Semnification

N -the number of the planks; K ? the number of the workers
Li -the maximal number of planks that can be painted by worker i
Pi -the sum received by worker i for a painted plank
Si -the plank in front of which sits the worker i

Output

The output contains a single integer, the total maximal income.

Sample Input

8 4
3 2 2
3 2 3
3 3 5
1 1 7

Sample Output

17

Hint

Explanation of the sample:

the worker 1 paints the interval [1, 2];

the worker 2 paints the interval [3, 4];

the worker 3 paints the interval [5, 7];

the worker 4 does not paint any plank

Source

Romania OI 2002


程序

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;

int dx[4]={-1,1,0,0};
int dy[4]={0,0,-1,1}; 
int m,n;
long long f[20000];
long long ans;

struct Node{
    long long L,P,S;
} a[110];

bool cmp(Node a,Node b){
    return a.S<b.S;
}

void dp(){
    for(int i=0;i<n;i++){
        int k=a[i].S;
        for(int j=a[i].S+a[i].L-1;j>=a[i].S;j--){
            if(j<=m&&j-a[i].L<=0)
                f[j]=max(f[j],j*a[i].P);
                else if(j<=m)
                    f[j]=max(f[j],f[k-1]+(j-k+1)*a[i].P);
            if(j-a[i].L>0 && a[i].P*(a[i].L-(j-k))>f[k-1]-f[k-1-(a[i].L-(j-k))])
                k=j-a[i].L;
        }
        for(int j=a[i].S+a[i].L; j<=m; j++)
            f[j]=max(f[j],f[a[i].S+a[i].L-1]);
    }
    ans=f[m];
}
int main(){
    cin>>m>>n;
    for(int i=0;i<n;i++)
        cin>>a[i].L>>a[i].P>>a[i].S;
    sort(a,a+n,cmp);
    dp();
    cout<<ans<<endl;
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值