数论 斯特林公式 HDU 1018 Big Number

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 41597    Accepted Submission(s): 20377


Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

Sample Input
 
 
2
10
20
 
Sample Output
 
 
7
19
 1.运用斯特林公式便可以轻松解决,但是一定要注意,sum一定要定义成double的形式。

2.log10(i);得到的是double形式的数据。

#include<algorithm>
#include<iostream>
#include<cmath>
#include<cstring>
#include<cstdio>
using namespace std;
int main()
{
	int c,n;
	double sum=0;
	cin>>c;
	while(c--)
	{
		cin>>n;
		sum=0;
		for(int i=1;i<=n;i++)
		   sum=sum+log10(i);
		cout<<(int)sum+1<<endl;
	}
	return 0;
} 

第二种:

   1.纯正的用斯特林公式,但一定要注意记住 π和e的取值。

   2.还要牢牢记住公式:

     

  n! \approx \sqrt{2\pi n}\, \left(\frac{n}{e}\right)^{n}.

  log10(n!)=0.5*log10(2πn)+n*log10(n)-n*log10(e).

 

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
using namespace std;
#define pi 3.14159265358
#define e   2.71828182
int main()
{
	double sum=0;
	int c,n;
	cin>>c;
	while(c--)
	{
		sum=0;
		cin>>n;
		sum=0.5*(log10(2*pi*n))+log10(n)*n-log10(e)*n;
		cout<<(int)sum+1<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值