Candies
Time Limit: 1500MS | Memory Limit: 131072K | |
Total Submissions: 37835 | Accepted: 10647 |
Description
During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.
snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?
Input
The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers A, B and c in order, meaning that kid A believed that kid B should never get over c candies more than he did.
Output
Output one line with only the largest difference desired. The difference is guaranteed to be finite.
Sample Input
2 2
1 2 5
2 1 4
Sample Output
5
Hint
32-bit signed integer type is capable of doing all arithmetic.
Source
POJ Monthly--2006.12.31, Sempr
1.Dijksra算法介绍:参考
2.本题从哪里看得出来是最短路径的题目?2比1 多的糖果数目不得超过5个,2和1就可以建立相应关系。1比2多的数目不得超过 4个,1和2也就可一建立关系,最后形成就是图。
3.vector<vector<candy> >cd(namx);vector定义大小namx:
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<queue>
#include<vector>
#include<cstring>
using namespace std;
#define namx 30006
struct candy
{
int k;
int w;
bool operator<(const candy &c)const
{
return w>c.w;
}
candy(int kk,int ww):k(kk),w(ww){};
candy(){};
};
priority_queue<candy>q;
vector<vector<candy> >cd(namx);//定义邻接表
int n,m;
int vis[namx];
void dijkstra(vector<vector<candy> >&cd)
{
candy p;
p.k=1;
p.w=0;//自己到自己的距离是0
q.push(p);
while(!q.empty())
{
p=q.top();
q.pop();
if(vis[p.k])
continue;
vis[p.k]=1;
if(p.k==n) break;
for(int i=0;i<cd[p.k].size();i++)
{
candy t;
t.k=cd[p.k][i].k;
if(vis[t.k]) continue;
t.w=cd[p.k][i].w+p.w;
q.push(t);
}
}
printf("%d\n",p.w);
}
int main()
{
//while(cin>>n>>m)
//{
cin>>n>>m;
memset(vis,0,sizeof(vis));
for(int i=1;i<=m;i++)
{
int a,b,c;
scanf("%d%d%d",&a,&b,&c);
cd[a].push_back(candy(b,c));
}
dijkstra(cd);
//}
return 0;
}
vector cd 用resize()函数定义大小:
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<queue>
#include<vector>
#include<cstring>
using namespace std;
#define namx 30006
struct candy
{
int k;
int w;
bool operator<(const candy &c)const
{
return w>c.w;
}
candy(int kk,int ww):k(kk),w(ww){};
candy(){};
};
priority_queue<candy>q;
vector<vector<candy> >cd;
int n,m;
int vis[namx];
void dijkstra(vector<vector<candy> >&cd)
{
candy p;
p.k=1;
p.w=0;//自己到自己的距离是0
q.push(p);
while(!q.empty())
{
p=q.top();
q.pop();
if(vis[p.k])
continue;
vis[p.k]=1;
if(p.k==n) break;
for(int i=0;i<cd[p.k].size();i++)
{
candy t;
t.k=cd[p.k][i].k;
if(vis[t.k]) continue;
t.w=cd[p.k][i].w+p.w;
q.push(t);
}
}
printf("%d\n",p.w);
}
int main()
{
//while(cin>>n>>m)
//{
cin>>n>>m;
memset(vis,0,sizeof(vis));
cd.clear();
cd.resize(n+1);//vector 中的resize()函数用来给vector预分配存储空间大小
for(int i=1;i<=m;i++)
{
int a,b,c;
scanf("%d%d%d",&a,&b,&c);
cd[a].push_back(candy(b,c));
}
dijkstra(cd);
//}
return 0;
}