最短路SPFA—Candies(POJ - 3159)

题目链接:>_>

题目:Candies

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers A, B and c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4

Sample Output

5

Hint

32-bit signed integer type is capable of doing all arithmetic.

题意:

n个人,m个信息,每行的信息是3个数字,A,B,C,表示B比A多出来的糖果不超过C个,问你,n号人最多比1号人多几个糖果。

AC代码:

#include<stack>
#include<algorithm>
#include<cstring>
#include<stdio.h>
#include<iostream>
using namespace std;
#define ll long long
#define itn int
const int maxn = 300005;
const int maxm = 1500005;
const ll inf = 0x3f3f3f3f;
int cnt;
int dis[maxn], vis[maxn];
int head[maxm], outqueue[maxm];
struct node {
	int to, next, w;
}x[maxn];

int n, m;
void add(int start, int endd, int w) {
	x[cnt].w = w;
	x[cnt].to = endd;
	x[cnt].next = head[start];
	head[start] = cnt++;
}

void init() {
	cnt = 0;
	memset(head, -1, sizeof head);
	memset(x, 0, sizeof x);
	memset(dis, inf, sizeof dis);
	memset(vis, 0, sizeof vis);
	memset(outqueue, 0, sizeof outqueue);
}

bool spfa() {
	stack<int>q;
	int i;
	q.push(1);
	vis[1] = 1;
	dis[1] = 0;
	while (!q.empty()) {
		int u = q.top();
		q.pop();
		vis[u] = 0;
		outqueue[u]++;
		if (outqueue[u] > n)return 0;
		for (i = head[u]; i != -1; i = x[i].next) {
			int v = x[i].to;
			if (dis[v] > dis[u] + x[i].w) {
				dis[v] = dis[u] + x[i].w;
				if (!vis[v]) {
					vis[v] = 1;
					q.push(v);
				}
			}
		}
	}
}

int main() {
	init();
	scanf("%d %d", &n, &m);
	int i, j;
	int q1, q2, q3;
	for (i = 0; i < m; i++) {
		scanf("%d %d %d", &q1, &q2, &q3);
		add(q1, q2, q3);
	}
	spfa();
	cout << dis[n] << endl;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值