ERROR: Could not build wheels for lxml, which is required to install pyproject.toml-based projects

Python安装 lxml时报错如下:

pip install lxml

在这里插入图片描述

我的解决办法,执行命令:

python3 -m pip install --upgrade pip setuptools wheel

然后再安装:

pip install lxml

之前安装 xlwings 也报错,现在也成功了

 pip install xlwings

如果不行,按照下面执行:

(1)下python版本对应.whl文件,下载地址:https://pypi.org/

(2)搜索包名(想安装什么模块就搜自己需要的):

在这里插入图片描述

(3)找到对应版本然后点击:

在这里插入图片描述

(4) 点击下载:

在这里插入图片描述

(5)下载对应whl文件

在这里插入图片描述

(6)找到文件下面的路径,执行安装命令(我的whl文件放在桌面,后面是包所在路径和包名):

pip install /Users/sunshiyu/Desktop/lxml-4.9.3-pp39-pypy39_pp73-macosx_11_0_x86_64.whl

如果还不能解决

可以到这里找找解决办法 installing packages
在这里插入图片描述

参考:

已解决Building wheel for lxml (setup.py) … error

  • 14
    点赞
  • 26
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值