(NYoj 269) VF --经典DP问题--下一个状态为前多个状态之和

VF
时间限制:1000 ms | 内存限制:65535 KB
难度:2
描述
Vasya is the beginning mathematician. He decided to make an important contribution to the science and to become famous all over the world. But how can he do that if the most interesting facts such as Pythagor’s theorem are already proved? Correct! He is to think out something his own, original. So he thought out the Theory of Vasya’s Functions. Vasya’s Functions (VF) are rather simple: the value of the Nth VF in the point S is an amount of integers from 1 to N that have the sum of digits S. You seem to be great programmers, so Vasya gave you a task to find the milliard VF value (i.e. the VF with N = 109) because Vasya himself won’t cope with the task. Can you solve the problem?
输入
There are multiple test cases.
Integer S (1 ≤ S ≤ 81).
输出
The milliard VF value in the point S.
样例输入
1
样例输出
10
来源
USU Junior Championship March’2005
上传者
李文鑫

分析:
题目意思我是读了很久才读懂。。。
题意: 给你一个s,问你在1~1000000000之间所有的整数中,各位数之和为s的数有多少个?
典型的DP思维:题目问前十位数和为s的数有多少个?那么我们就这样定义状态dp[i][j]表示:前i位数和为j的数有多少个。
那么状态怎么转换呢?假设第i位为k,那么dp[i][j]=dp[i-1][j-k] (前i-1位和为j-k的个数)。k有很多种情况,我们将k的所有情况加起来就可以了。(k>=0 && k<=j && j<=s)

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int dp[10][90];

void init()
{
    memset(dp,0,sizeof(dp));
    for(int i=1;i<=9;i++)
        dp[1][i]=1;
    for(int i=2;i<=9;i++)
    {
        for(int j=1;j<=i*9;j++)
        {
            for(int k=0;k<=9 && k<=j;k++)
            {
                dp[i][j]+=dp[i-1][j-k];
            }
        }
    }
}
int main()
{
    int s;
    init();
    while(scanf("%d",&s)!=EOF)
    {
        if(s==1)
        {
            printf("10\n");continue;
        }
        int ans=0;
        for(int i=1;i<=9;i++)
            ans+=dp[i][s];
        printf("%d\n",ans);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值