(LA3026) Period -- KMP again (KMP 模板)

Period
Time Limit: 3000MS 64bit IO Format: %lld & %llu

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and
126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 ≤ i ≤ N)
we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be
written as AK, that is A concatenated K times, for some string A. Of course, we also want to know
the period K.
Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains
N (2 ≤ N ≤ 1000000) the size of the string S. The second line contains the string S. The input file
ends with a line, having the number zero on it.
Output
For each test case, output ‘Test case #’ and the consecutive test case number on a single line; then, for
each prefix with length i that has a period K > 1, output the prefix size i and the period K separated
by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input
3
aaa
12
aabaabaabaab
0
Sample Output
Test case #1
2 2
3 3
Test case #2
2 2
6 2
9 3
12 4

题意:
给出一个字符串s,求出它的每个前缀的最短循环节。换句话说就是对于每个i,求一个最大的整数k>1,使得s的前i个字符组成的前缀是某个字符串重复K次得到。输出所有存在k的i和对应的k.
比如样例:aabaabaabaab 只有当i=2,6,9,12时存在k,且分别为2,2,3,4。

分析:
如果你已经学过KMP算分的话,f[i]表示前i个字符的前缀和后缀相等的最大长度。所以“错位部分”的长度为i-f[i].
如果这i个字符组成一个周期川,那么“错位部分”刚好就是一个循环节。所以有k*(i-f[i])=i,所有k=i/(i-f[i]).

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

const int maxn = 1000000+10;
char s[maxn];
int f[maxn],n;

void getfail(char *s,int *f)
{
    f[0]=f[1]=0;
    for(int i=1; i<n; i++)
    {
        int j=f[i];
        while(j && s[i]!=s[j]) j=f[j];
        f[i+1]=s[i]==s[j]?j+1:0;
    }
}


int main()
{
    int kase=1;
    while(scanf("%d",&n)==1 && n)
    {
        scanf("%s",s);
        getfail(s,f);
        printf("Test case #%d\n",kase++);
        for(int i=2; i<=n; i++)
        {
            if(f[i] && i%(i-f[i])==0)
                printf("%d %d\n",i,i/(i-f[i]));
        }
        printf("\n");
    }
    return 0;
}

KMP 函数:

void find(char * T,char * P,int * f)
{
    int n=streln(T),m=strlen(P);
    getfail(P,f);
    int j=0;//匹配数
    for(int i=0;i<n;i++)
    {
        while(j && T[i]!=P[j]) j = f[j];
        if(T[i]==P[j]) j++;
        if(j==m) printf("%d\n",i-m+1);
    }
}

//自己和自己匹配
void getfail(char* P,int* f)
{
    f[0]=f[1]=0;
    int m=strlen(P);
    for(int i=1;i<m;i++)
    {
        int j=f[i];
        while(j && P[i]!=P[j]) j=f[j];
        f[i+1]=P[i]==P[j]?j+1:0;
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值