Snowflake Snow Snowflakes
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 39257 Accepted: 10282
Description
You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.
Input
The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.
Output
If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.
Sample Input
2
1 2 3 4 5 6
4 3 2 1 6 5
Sample Output
Twin snowflakes found.
Source
CCC 2007
哈希讲解: http://www.cnblogs.com/yangecnu/p/Introduce-Hashtable.html
题意:
给你n片雪花,每片雪花有六边,判断有没有相同的雪花,即从任意位置开始顺时针或逆时针的顺序一样。
分析:
在所有的雪花中,只有六个边是一样的(不管顺序)的雪花才有可能是一样的。所以我们可以把雪花分成很多“同分异构体”,在比较时只需要比较“同分异构的”就可以了。那我们怎么把这些雪花分类呢?可以进行排序,但是很不方便。所以我们可以用哈希表,将六边的和相等的归为一类(拥有相同的键值)。然后在进行比较即可。
AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
using namespace std;
const int prime = 999983;
struct flake
{
int v[6];
flake* next;
flake() {next = NULL; }
};
flake flakes[100005];
struct Entry
{
flake* key;
Entry() {key = NULL;}
};
Entry hashdata[prime];
int gethashcode(flake& f)
{
int ans = 0;
for(int i=0;i<6;i++)
ans += f.v[i] % prime;
return ans % prime;
}
bool flakesame(flake& f1, flake& f2)
{
int v[12];
memcpy(v,f1.v,sizeof(f1.v));
memcpy(v+6,f1.v,sizeof(f1.v));
int i,j,k;
for(i=0;i<6;i++)
{
for(j=i,k=0;k<6;k++,j++)
{
if(v[j]!=f2.v[k]) break;
}
if(k == 6) return true;
}
for(i=0,j=11;i<6;i++,j--)
{
int t = v[i];
v[i] = v[j];
v[j] = t;
}
for(i=0;i<6;i++)
{
for(j=i,k=0;k<6;k++,j++)
{
if(v[j]!=f2.v[k]) break;
}
if(k == 6) return true;
}
return false;
}
bool inserthash(flake& f)
{
int id = gethashcode(f);
if(hashdata[id].key==NULL)
{
hashdata[id].key = &f;
return true;
}
else
{
flake *p = hashdata[id].key;
flake *pre;
while(p)
{
if(flakesame(*p,f))
return false;
pre = p;
p = p->next;
}
pre->next = &f;
return true;
}
}
int main()
{
int n,flag = 0;
while(scanf("%d",&n)!=EOF)
{
flag = 0;
for(int i=0;i<n;i++)
{
scanf("%d%d%d%d%d%d",flakes[i].v,flakes[i].v+1,flakes[i].v+2,flakes[i].v+3,flakes[i].v+4,flakes[i].v+5);
if(!flag)
{
if(!inserthash(flakes[i]))
flag = 1;
}
}
if(flag) printf("Twin snowflakes found.\n");
else printf("No two snowflakes are alike.\n");
}
return 0;
}