(POJ 3468)A Simple Problem with Integers 线段树区间修改入门讲解

C - A Simple Problem with Integers
Time Limit:5000MS Memory Limit:131072KB 64bit IO Format:%lld & %llu

POJ 3468
Description
You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input
The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.
“Q a b” means querying the sum of Aa, Aa+1, … , Ab.

Output
You need to answer all Q commands in order. One answer in a line.

Sample Input
10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output
4
55
9
15
Hint
The sums may exceed the range of 32-bit integers.

裸的线段树区间修改
看了刘汝佳的白书上讲的,然后在看看下面的内容就可以入门了
http://www.cnblogs.com/Inkblots/p/4919193.html 博主讲的很清晰!!!

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#define LL long long
using namespace std;

const int maxn = 100005;
int n,q;
int s[maxn];
LL ans;

struct node
{
    int x,l,r;
    LL value;
    LL add;
};

node tr[4*maxn];

void build(int x,int l,int r)
{
    tr[x].l = l; tr[x].r = r;
    if(l==r)
    {
        tr[x].value = s[l];
        return ;
    }
    int mid = (l+r)/2;
    build(2*x,l,mid);
    build(2*x+1,mid+1,r);
    tr[x].value = tr[2*x].value + tr[2*x+1].value;
    tr[x].add = 0;
}

void update(int x,int l,int r,int m)
{
    tr[x].value += m*(r-l+1);

    if(tr[x].l == l && tr[x].r == r)
    {
        tr[x].add += m;
        return ;
    }

    if(tr[x].add)
    {
        tr[2*x].add += tr[x].add;
        tr[2*x].value += tr[x].add*(tr[2*x].r - tr[2*x].l + 1);
        tr[2*x + 1].add += tr[x].add;
        tr[2*x + 1].value += tr[x].add*(tr[2*x +1].r - tr[2*x + 1].l + 1);
        tr[x].add = 0;
    }

    int mid = (tr[x].r + tr[x].l)/2;
    if(r <= mid) update(2*x,l,r,m);
    else if(l > mid) update(2*x+1,l,r,m);
    else
    {
        update(2*x,l,mid,m);
        update(2*x+1,mid+1,r,m);
    }
}

void query(int x,int l,int r)
{
    if(tr[x].l == l && tr[x].r == r)
    {
        ans += tr[x].value;
        return ;
    }

    if(tr[x].add)
    {
        tr[2*x].add += tr[x].add;
        tr[2*x].value += tr[x].add*(tr[2*x].r - tr[2*x].l + 1);
        tr[2*x + 1].add += tr[x].add;
        tr[2*x + 1].value += tr[x].add*(tr[2*x +1].r - tr[2*x + 1].l + 1);
        tr[x].add = 0;
    }

    int mid = (tr[x].r + tr[x].l)/2;
    if(r <= mid) query(2*x,l,r);
    else if(l > mid) query(2*x+1,l,r);
    else
    {
        query(2*x,l,mid);
        query(2*x+1,mid+1,r);
    }
}


int main()
{
    while(scanf("%d%d",&n,&q)!=EOF)
    {
        for(int i=1;i<=n;i++)
            scanf("%d",&s[i]);
        build(1,1,n);
        char ch;
        int l,r,ad;
        while(q--)
        {
            scanf("\n%c",&ch);
            if(ch == 'C')
            {
                scanf("%d%d%d",&l,&r,&ad);
                update(1,l,r,ad);
            }
            else
            {
                ans = 0;
                scanf("%d%d",&l,&r);
                query(1,l,r);
                printf("%lld\n",ans);
            }
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值