(HDU 1078) FatMouse and Cheese 记忆化搜索

FatMouse and Cheese
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8705 Accepted Submission(s): 3653

Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he’s going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse – after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

Input
There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) … (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), … (1,n-1), and so on.
The input ends with a pair of -1’s.

Output
For each test case output in a line the single integer giving the number of blocks of cheese collected.

Sample Input
3 1
1 2 5
10 11 6
12 12 7
-1 -1

Sample Output
37

Source
Zhejiang University Training Contest 2001

题意:
有一只老鼠在网格中吃奶酪,从(1,1)出发,每次可以往一个水平和垂直方向(即上,下,左,右)上最多走k格,且下一格的奶酪数要比之前的大。问最多可以吃多少奶酪?

分析:
当k=1时,从(1,1)出发可以有四个位置,再从这四个位置出发。。。很明显是一个搜索题。
但是直接搜索会有很多重复的计算,所以我们利用记忆化搜索,即用dp[i][j]记录下从(i,j)出发最多可以吃多少奶酪,然后进行深搜即可。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;

int a[105][105], dp[105][105];
int dir[4][2] = {1,0,-1,0,0,1,0,-1};
int n,k;


int DFS(int x,int y)
{
    int mmax = 0;
    if(!dp[x][y])
    {
        for(int i=0;i<4;i++)
        {
            for(int j=1;j<=k;j++)
            {
                int X = x+dir[i][0]*j;
                int Y = y+dir[i][1]*j;
                if(X>=1 && X<=n && Y>=1 && Y<=n && a[X][Y]>a[x][y])
                {
                    mmax = max(mmax,DFS(X,Y));
                }
            }
        }
        dp[x][y] = mmax + a[x][y];
    }
    return dp[x][y];
}

int main()
{
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        if(n == -1) break;
        for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
        {
            scanf("%d",&a[i][j]);
            dp[i][j] = 0;
        }
        printf("%d\n",DFS(1,1));
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值