(POJ1080)Human Gene Functions <DP,最长公共子序列变形>

Human Gene Functions
Description

It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because these can be used to diagnose human diseases and to design new drugs for them.

A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function.
One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet.

A database search will return a list of gene sequences from the database that are similar to the query gene.
Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed.

Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one.
Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity
of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of
the genes to make them equally long and score the resulting genes according to a scoring matrix.

For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT–TAG. A space is denoted by a minus sign (-). The two genes are now of equal
length. These two strings are aligned:

AGTGAT-G
-GT–TAG

In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix.
这里写图片描述
denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9.

Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions):

AGTGATG
-GTTA-G

This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the
similarity of the two genes is 14.
Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence is at least one and does not exceed 100.
Output

The output should print the similarity of each test case, one per line.
Sample Input

2
7 AGTGATG
5 GTTAG
7 AGCTATT
9 AGCTTTAAA
Sample Output
14
21

Source
Taejon 2001

转载:http://blog.csdn.net/lihao21

题意
给定两个基因字符串,用A,C,G,T表示其组成成分。若两个基因的长度不一样,可以通过在两个串中分别添加空格使其长度一致。当其长度一样后,分别计算对应位置上的两个字母的分数,并将所有的分数相加便得到两个串的相似度分数。求,两个基因串的最高分数。

分析
给定两个基因串Gn, Gm,要求其最高分数f(n, m),有以下两种情况:
1)G[n] = G[m],则f(n, m) = f(n-1, m-1) + 5;
2)G[n] != G[m], 则可分三种情况:
i.在Gn后添加空格,其分数为f(n, m) = f(n, m-1) + scores[4][Index(G[m])];
ii. 在Gm后添加空格,其分数为f(n, m) = f(n-1, m) + scores[Index(G[n])][4];
iii. 直接使用Gn, Gm的最后两个字配对,其分数为f(n, m) = f(n-1, m-1) + scores[Index(G[n])][Index(G[m])];
其中,Index()返回字母在分数矩阵中的所在行或列。(详见原题分数矩阵)
再取i, ii, iii这三种情况的最大值即为Gn, Gm的最高分数。
初始化:
我们要初始化所有dp[i][0],dp[0][i]的情况。
注意:当s1[i] 和 s2[0]配对的时候,说明s1[1~i]都和’-‘配对,所以dp[i][0]= dp[i-1][0] + s[ind1][4]],对于dp[0][i]同理。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;

int s[5][5]={5,-1,-2,-1,-3,-1,5,-3,-2,-4,-2,-3,5,-2,-2,-1,-2,-2,5,-1,-3,-4,-2,-1,0};
char s1[110],s2[110];
int dp[110][110];
int n,m;

int getindex(char c)
{
    if(c == 'A') return 0;
    else if(c == 'C') return 1;
    else if(c == 'G') return 2;
    else if(c == 'T') return 3;
    else return 4;
}

int max3(int a,int b,int c)
{
    return max(a,max(b,c));
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%s",&n,&s1);
        scanf("%d%s",&m,&s2);
        //初始化
        for(int i=1;i<=n;i++)
        {
            int ind = getindex(s1[i-1]);
            dp[i][0] = dp[i-1][0] + s[ind][4];
        }
        for(int i=1;i<=m;i++)
        {
            int ind = getindex(s2[i-1]);
            dp[0][i] = dp[0][i-1] + s[4][ind];
        }

        //计算dp
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                if(s1[i-1] == s2[j-1])
                    dp[i][j] = dp[i-1][j-1] + 5;
                else
                {
                    int ind1 = getindex(s1[i-1]);
                    int ind2 = getindex(s2[j-1]);
                    int ans1 = dp[i][j-1] + s[4][ind2];
                    int ans2 = dp[i-1][j] + s[ind1][4];
                    int ans3 = dp[i-1][j-1] + s[ind1][ind2];
                    dp[i][j] = max3(ans1,ans2,ans3);
                }
            }
        }
        printf("%d\n",dp[n][m]);
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值