(POJ1845)Sumdiv <约数和定理 + 快速幂求模 + 二分求等比数列和的模>

Sumdiv
Description

Consider two natural numbers A and B. Let S be the sum of all natural divisors of A^B. Determine S modulo 9901 (the rest of the division of S by 9901).
Input

The only line contains the two natural numbers A and B, (0 <= A,B <= 50000000)separated by blanks.
Output

The only line of the output will contain S modulo 9901.
Sample Input

2 3
Sample Output

15
Hint

2^3 = 8.
The natural divisors of 8 are: 1,2,4,8. Their sum is 15.
15 modulo 9901 is 15 (that should be output).
Source

Romania OI 2002

题意:
给你A,B,求A^B的因子和mod 9901

分析:
分解a的质因数a=p1^t1*p2^t1……..

每个质因数对sum的贡献: 当除去质因数p1时的因数和为sum,当计入p1时,因子和变成sum*p1^0+sum*p1^1+sum*p1^2……+sum*p1^t1

也就是所有的sum=【1+p1+p1^2+p1^3+…+p1^t1】*【p2…..】【p3…】

然后由于是a^b,所以最后是

sum=sum=【1+p1+p1^2+p1^3+…+p1^(t1*b)】*【p2…..】【p3…】

显然就是求关于a的所有质因数的一个 等比数列之和前n项和.

直接二分递归求:
求 1 + p + p^2 + p^3 +…+ p^n
当n=奇数,会有偶数项,我们把1和p^(n/2+1)放在一起 p和p^(n/2+1+1)放在一起,以此类推
最后提公因式,得到【1+p^(n/2+1)】*【1+p+p^2+p^3+….+p^(n/2-1)】右边恰为原式的一半

当n=偶数,同理得到【1+p^(n/2)】*【1+p+p^2+….p^(n/2)】
因此二分递归则可以得到答案

分析:

#include<stdio.h>
#include<algorithm>
#include<math.h>
#include<iostream>
using namespace std;
const int maxn = 1e6;
long long quickpow(long long  m,long long n,long long k)
{
    long long b = 1;
    while (n > 0)
    {
          if (n & 1)
             b = (b*m)%k;
          n = n >> 1 ;
          m = (m*m)%k;
    }
    return b;
}
int cnt[maxn];
int num[maxn];
int tot = 0;
void factorization(int x)
{
    for(int i=2;i*i<=x;i++)
    {
        if(x%i==0)
        {
            cnt[tot]=i;
            num[tot]=0;
            while(x%i==0)
            {
                x/=i;
                num[tot]++;
            }
            tot++;
        }
    }
    if(x!=1)
    {
        cnt[tot]=x;
        num[tot]=1;
        tot++;
    }
}

long long Sum_of_geometric_progression(long long p,long long n,long long mod)
{
    if(n==0)return 1;
    if(n&1)
        return ((1+quickpow(p,n/2+1,mod))%mod*Sum_of_geometric_progression(p,n/2,mod)%mod)%mod;
    else
        return (quickpow(p,n/2,mod)+(1+quickpow(p,n/2+1,mod))%mod*Sum_of_geometric_progression(p,(n-1)/2,mod)%mod)%mod;
}

int main()
{
    int A,B;
    while(scanf("%d%d",&A,&B)!=EOF)
    {
        tot = 0;
        factorization(A);
        int ans = 1;
        for(int i=0;i<tot;i++)
            ans = (ans*Sum_of_geometric_progression(cnt[i],B*num[i],9901))%9901;
        printf("%d\n",ans);
    }
    return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值