(POJ 2155)Matrix (复习必看题)经典二维树状数组题目 + 树状数组的论文讲解

Matrix
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 27332 Accepted: 9994
Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using “not” operation (if it is a ‘0’ then change it into ‘1’ otherwise change it into ‘0’). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

  1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
  2. Q x y (1 <= x, y <= n) querys A[x, y].
    Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format “Q x y” or “C x1 y1 x2 y2”, which has been described above.
Output

For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.
Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1
Sample Output

1
0
0
1
Source

POJ Monthly,Lou Tiancheng

题意:
有一个n*n的矩阵,开始时所有数都是0,并且数不是1就是0,现在进行两种操作
1:C x1 y1 x2 y2 将以(x1,y1)为左上角(x2,y2)为右上角的矩形中的所有是取反:0变成1 ,1变成0
2:Q x y 问你在(x,y)处的数是0还是1

分析:
最好的讲解就是相关的论文了:http://download.csdn.net/detail/lenleaves/4548401

以下都是我自己看了论文之后进行的思维的整理,方便自己今后复习:

由于题目要求某一位置的值,我们只需要记录每一个位置改变的次数,而后进行%2运算就可以得出答案来。
但是对于每一个位置变换的次数我们没法用枚举来实现,所以只能使用树状数组了

对于树状数组的题目,我们进行的都是“点”修改,和区间值查询

对于getsum()函数,是很快的获得某一点之前的所以得值之和
对于update()函数,是对某一点进行更新,那么在他之后的所有的位置进行getsum()函数时都会进行相应的改变

而这一题是区间修改和点查询,所以我们要想办法使得在查询某一位置的值的时候是利用getsum()来求得该位置之前的和(即将他的值的含义表示为前缀和),而更新的时候可以修改之后位置的所有的值

而我们向利用树状数组的原因是因为暴力一定会超时,没法枚举要改变的区间,所以我们用几个关键点的更新从而来实现区间的改变

对于这一题而言是所以的关键点进行一样的操作,而对于一般的问题,我们只要使最后的结果正确即可,通过加减操作来实现

AC代码:

#include <iostream>
#include <cstdio>
using namespace std;

const int maxn = 1010;

int c[maxn][maxn];
int t,n,q;
int x1,y1,x2,y2;
char s[5];

int lowbit(int x)
{
    return x & (-x);
}

void update(int x,int y)
{
    for(int i=x;i<=n;i+=lowbit(i))
    {
        for(int j=y;j<=n;j+=lowbit(j))
            c[i][j]++;
    }
}

int getsum(int x,int y)
{
    int sum = 0;
    for(int i=x;i>0;i-=lowbit(i))
    {
        for(int j=y;j>0;j-=lowbit(j))
            sum += c[i][j];
    }
    return sum;
}

int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&q);
        for(int i=0;i<=n;i++)
            for(int j=0;j<=n;j++) c[i][j] = 0;
        for(int i=0;i<q;i++)
        {
            scanf("%s",s);
            if(s[0] == 'C')
            {
                scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
                update(x1,y1);
                update(x1,y2+1);
                update(x2+1,y1);
                update(x2+1,y2+1);
            }
            else if(s[0] == 'Q')
            {
                scanf("%d%d",&x1,&y1);
                printf("%d\n",getsum(x1,y1)%2);
            }

        }
        printf("\n");
    }
    return 0;
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值