数据结构实验之栈一:进制转换

数据结构实验之栈一:进制转换

Time Limit: 1000MS  Memory Limit: 65536KB
Problem Description
输入一个十进制整数,将其转换成对应的R(2<=R<=9)进制数,并输出。
Input
第一行输入需要转换的十进制数;
第二行输入R。
Output
输出转换所得的R进制数。
Example Input
1279
8
Example Output
2377
Code realization
#include <stdio.h>
#include <stdlib.h>
#define maxn 100000
typedef int SElemType;
typedef struct node
{
	SElemType *base;   //栈底指针
	SElemType *top;   //栈顶指针
	int stacksize;  //当前栈的最大容量
}SqStack;

void InitStack(SqStack &S)
{
	S.base = (SElemType *)malloc(maxn*sizeof(SElemType));
	S.top = S.base;
	S.stacksize = maxn;
}
void creat(SqStack &S, int n,int m)
{
	while(n)
	{
		*S.top = n%m;
		n = n/m;   //  n/=m
		S.top++;
	}
}
void output(SqStack &S)
{
	while(S.top>S.base)
	{
		S.top--;
		printf("%d",*S.top);
	}
}
int main()
{
	int n,m;
	SqStack S;
	scanf("%d %d",&n,&m);
	InitStack(S);
	creat(S,n,m);
	output(S);
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值