POJ 1068 Parencodings(模拟法)

Parencodings
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%lld & %llu
Appoint description: 

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 
	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

题意:S数组是一些括号对,其中:P数组是每个右括号前的左括号数;W数组是每个右括号跟它相匹配的左括号之间相隔的右括号数(包括它本身)。现给出P数组,求W数组。

思路:不必还原原来的括号数组,用一个v数组记录每两个右括号间的左括号数,即:v[i]=p[i]-p[i-1]。如果v[i]>0,表明该右括号前就有跟它匹配的左括号,则显然w[i]=1,v[i]要减1,表明它前面未配对的左括号少了一个;如果v[i]=0,表明该右括号前没有左括号,即它前面还是右括号,则要往前倒才能找到跟它匹配的左括号,我们用cnt来数它前面的右括号数,初始化为1(先算上它自己):如果v[i-1]也=0,则表明它前面还是右括号,cnt++,继续循环;如果v[i-1]>=1,说明在这个右括号前能找到配对的左括号了,v[i-1]要减1,然后w[i]=cnt+1(加上这个右括号),并且立马break掉。

#include<cstdio>
#include<cstring>
using namespace std;

int p[25];
int w[25];
int v[25];
//char c[100];

int main()
{
	int T,n;
	scanf("%d",&T);
	while(T--)
	{
		int i;
		int k=1;
		memset(p,0,sizeof(p));
		memset(w,0,sizeof(w));
		//memset(c,0,sizeof(c));
		memset(v,0,sizeof(v));
		scanf("%d",&n);
		for(i=1; i<=n; i++)
			scanf("%d",&p[i]);
			
		/*for(i=1; i<=n; i++)	//还原括号 
		{
			int j=p[i]-p[i-1];
			if(j>0)
			{
				while(j--)
					c[k++]='(';
				c[k++]=')';
			}
			else
			{
				c[k]=')';
				k++;
			}
		}*/

		for(i=1;i<=n;i++)
			v[i]=p[i]-p[i-1];
		int j;
		int cnt;
		for(i=1;i<=n;i++)
		{
			if(v[i]>0)
			{
				w[i]=1;
				v[i]--;
			}
			else
			{
				cnt=1;
				for(j=i-1;j>=1;j--)
				{
					if(v[j]<1)
					  cnt++;
					else
					{
						v[j]--;
						w[i]=cnt+1;
						break;
					}		  
				}
			}
		}
		for(i=1; i<n; i++)
			printf("%d ",w[i]);
		printf("%d\n",w[n]);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值