Hust oj 1753 Triangular numbers(三角数)

Triangular numbers
Time Limit: 1000 MSMemory Limit: 65536 K
Total Submit: 65(43 users)Total Accepted: 43(41 users)Rating: Special Judge: No
Description

A triangular number is the number of dots in an equilateral triangle uniformly filled with dots. For example, three dots can be arranged in a triangle; thus three is a triangular number. The n-th triangular number is the number of dots in a triangle with n dots on a side.

Your task is to find out if a given integer is a triangular number.

Input

There are multiple test cases, processing to the end of file.

For each case:

The first line contains the single number n (1 n 500) — the given integer.

Output

For each case:

If the given integer is a triangular number output YES, otherwise output NO.

Sample Input
1
2
3
Sample Output
YES
NO
YES
 
读完了题没看明白什么叫三角数,于是找了找资料,然后就感觉这题好傻。。。

 三角数即 『 1, 3, 6, 10, 15, 21, 28, 36, 45, 55, 66, 78, ......』

1 = 1

1 + 2 = 3

1 + 2 + 3 = 6

1 + 2 + 3 + 4 = 10

1 + 2 + 3 + 4 + 5 = 15

1 + 2 + 3 + 4 + 5 + ... ...

规律很明显,F[n]=(n^2+n)/2,上代码
 
#include<iostream>
using namespace std;

int main()
{
    int i;
    int n;
    int a[501];
    for(i=1;i<=500;i++)
    {
        a[i]=i*(i+1)/2;
    }
    while(cin>>n)
    {
        int flag=0;
        for(i=1;i<=500;i++)
        {
            if(a[i]==n)
             {
                 flag=1;
                 break;
             }
        }
        if(flag==0)
            cout<<"NO"<<endl;
        else
            cout<<"YES"<<endl;
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值