POJ 2251___走迷宫 —— 解题报告 BFS

原题地址:http://poj.org/problem?id=2251

 

Dungeon Master

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 41530 Accepted: 15736

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 
L is the number of levels making up the dungeon. 
R and C are the number of rows and columns making up the plan of each level. 
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 

Escaped in x minute(s).


where x is replaced by the shortest time it takes to escape. 
If it is not possible to escape, print the line 

Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

 

题目大意:

给出一个三维空间迷宫,“.”代表可行走的空间,“#”代表不可行走的封闭间。从"S"开始,求到地点“E”的最短时间。

每次移动可在迷宫内上下左右前后移动。

 

解题思路:

BFS即可

 

代码思路:

1、用结构体存储长宽高和时间

2、命名2个开始与结束的结构体、一个将要执行的顺序体queue与一个正在执行的结构体x

3、三维遍历未访问过的所有空间

4、当第一次搜索到E位置时即可得到答案

 

核心:在每次三维延展时,第一次访问到的路径以后都不在访问,每条路径不相交,即可获得做最短路径!

 

代码:

#include <iostream>
#include <string.h>
using namespace std;
typedef class {
	public:
		int l,r,c;
		int depth;	// 耗时
} pf;

pf s,e;
bool maze[40][40][40];
int shortmin;

bool BFS(int i,int j,int k) {
	bool vist[40][40][40]= {false};
	pf queue [30000];
	int head,tail;
	queue[head=0].l=i;
	queue[tail=0].r=j;
	queue[0].c=k;
	queue[tail++].depth=0;

	vist[i][j][k]=true;

	while(head<tail) {
		pf x=queue[head++];

		if(x.l==e.l&&x.r==e.r&&x.c==e.c) {
			shortmin=x.depth;
			return true;
		}

		if(maze[x.l-1][x.r][x.c]&&!vist[x.l-1][x.r][x.c]) {
			vist[x.l-1][x.r][x.c]=true;
			queue[tail].l=x.l-1;
			queue[tail].r=x.r;
			queue[tail].c=x.c;
			queue[tail++].depth=x.depth+1;
		}

		if(maze[x.l][x.r-1][x.c]&&!vist[x.l][x.r-1][x.c]) {
			vist[x.l][x.r-1][x.c]=true;
			queue[tail].l=x.l;
			queue[tail].r=x.r-1;
			queue[tail].c=x.c;
			queue[tail++].depth=x.depth+1;
		}

		if(maze[x.l][x.r][x.c-1]&&!vist[x.l][x.r][x.c-1]) {
			vist[x.l][x.r][x.c-1]=true;
			queue[tail].l=x.l;
			queue[tail].r=x.r;
			queue[tail].c=x.c-1;
			queue[tail++].depth=x.depth+1;
		}

		if(maze[x.l+1][x.r][x.c]&&!vist[x.l+1][x.r][x.c]) {
			vist[x.l+1][x.r][x.c]=true;
			queue[tail].l=x.l+1;
			queue[tail].r=x.r;
			queue[tail].c=x.c;
			queue[tail++].depth=x.depth+1;
		}

		if(maze[x.l][x.r+1][x.c]&&!vist[x.l][x.r+1][x.c]) {
			vist[x.l][x.r+1][x.c]=true;
			queue[tail].l=x.l;
			queue[tail].r=x.r+1;
			queue[tail].c=x.c;
			queue[tail++].depth=x.depth+1;
		}

		if(maze[x.l][x.r][x.c+1]&&!vist[x.l][x.r][x.c+1]) {
			vist[x.l][x.r][x.c+1]=true;
			queue[tail].l=x.l;
			queue[tail].r=x.r;
			queue[tail].c=x.c+1;
			queue[tail++].depth=x.depth+1;
		}
	}
	return false;
}

int main() {
	std::ios::sync_with_stdio(false);
	int L,R,C;
	while(cin>>L>>R>>C&&L&&R&&C) {
		memset(maze,false,sizeof(maze));	//更新迷宫
		for(int i=1; i<=L; i++)
			for(int j=1; j<=R; j++)
				for(int k=1; k<=C; k++) {
					char temp;
					cin>>temp;
					if(temp=='.') maze[i][j][k]=true;
					if(temp=='S') {
						maze[i][j][k]=true;
						s.l=i;
						s.r=j;
						s.c=k;
					}
					if(temp=='E') {
						maze[i][j][k]=true;
						e.l=i;
						e.r=j;
						e.c=k;
					}
				}

		if(BFS(s.l,s.r,s.c))
			cout<<"Escaped in "<<shortmin<<" minute(s)."<<endl;
		else cout<<"Trapped!"<<endl;
	}
	return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
POJ2251是一个经典的题目,也被称为"水仙花的谜题"。该题目要求在一个三维的迷宫中找到从起点到终点的最短路径。 在这个题目中,迷宫由一个3D的数组表示,每个位置上的值代表了该位置的状态。其中,0表示可以通过的路径,1表示墙壁,2表示起点,3表示终点。你需要编写一个程序来找到从起点到终点的最短路径,并输出路径的长度。 解决这个问题的一种常见方法是使用广度优先搜索(BFS)算法。BFS算法可以从起点开始,逐层遍历迷宫中的位置,直到找到终点或者遍历完所有可达位置。在遍历过程中,你需要记录每个位置的距离和路径信息,以便找到最短路径。 以下是解决该问题的大致思路: 1. 定义一个队列,将起点加入队列,并标记起点已访问。 2. 使用循环来遍历队列中的元素,直到队列为空。 3. 在循环中,取出队列中的元素,并获取其相邻可达位置。 4. 对于每个相邻位置,判断是否为终点,如果是则输出最短路径长度并结束程序。 5. 如果不是终点,则判断该位置是否为可通过的路径,并且未被访问过。如果满足条件,则将该位置加入队列,并更新距离和路径信息。 6. 重复步骤2-5,直到找到终点或者遍历完所有可达位置。 这只是一个简单的介绍,实际解决该问题还需要考虑一些细节,比如如何表示迷宫、如何判断位置的合法性等。你可以在编写代码时参考相关的算法和数据结构知识。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值