原题
1078 Hashing
分数 25
全屏浏览
切换布局
作者 CHEN, Yue
单位 浙江大学
The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.
Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.
Input Specification:
Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤104) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.
Sample Input:
4 4
10 6 4 15
Sample Output:
0 1 4 -
代码长度限制
16 KB
时间限制
400 ms
内存限制
64 MB
栈限制
8192 KB
解法
主要使用:
- 筛法找素数
- 哈希中的平方探测法,注意index = (key + step * step) % size, step从0到size - 1
#include <iostream>
#include <cstring>
using namespace std;
const int N = 1e4 + 10;
int h[N]; // 输入数字i在mp上的索引为h[i]
bool mp[N]; // 在mp上的某个位置是否被占用
int max_size = 0;
bool prime[N];
int find(int m) {
for (int i = 2; i < N; i ++) {
if (!prime[i]) continue;
int j = i;
int k = 1;
do {
j = i * k;
prime[j] = false;
k ++;
}while (j <= m && j < N);
if (i >= m) return i;
}
return m;
}
void insert(int x, int temp) {
// h[x]设置为索引,索引不对则设为-1
int k = (temp % max_size);
int r = k;
int d = 0;
while (d <= max_size - 1) { // 该索引位已经被占领
if (!mp[r]) { // 没占领
h[x] = r;
mp[r] = true;
break;
}
d += 1;
r = (temp + d * d) % max_size;
}
}
int main() {
int m, n;
scanf("%d%d", &m, &n);
memset(prime, true, sizeof(prime));
memset(mp, false, sizeof(mp));
memset(h, -1, sizeof h);
max_size = find(m);
for (int i = 0; i < n; i ++) {
int temp;
scanf("%d", &temp);
insert(i, temp);
}
for (int i = 0; i < n; i ++) {
if (i == n - 1) {
if (h[i] != -1) printf("%d", h[i]);
else printf("-");
}
else {
if (h[i] != -1) printf("%d ", h[i]);
else printf("- ");
}
}
return 0;
}