1093 Count PAT‘s

原题

1093 Count PAT's

分数 25

全屏浏览

切换布局

作者 CAO, Peng

单位 Google

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 105 characters containing only P, A, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

2

代码长度限制

16 KB

时间限制

150 ms

内存限制

64 MB

栈限制

8192 KB

解法

遍历字符串,记录当前的p、pa、pat分别的数量:

  1. 遍历到P,则p++
  2. 遍历到A,则pa的数量即为当前的p的数量,即pa += p
  3. 遍历到T,则pat的数量即为当前的pa的数量,即pat += pa

注意要取模

#include <iostream>
#include <math.h>
#include <algorithm>
using namespace std;
typedef long long LL;

int main() {
    string str;
    cin >> str;
    LL p = 0, pa = 0, pat = 0;
    for (int i = 0; i < str.size(); i ++) {
        if (str[i] == 'P') p ++;
        else if (str[i] == 'A') pa += p;
        else if (str[i] == 'T') pat = (pat + pa) % 1000000007;
    }
    printf("%lld", pat);
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Scienteresting

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值