04-树6 Complete Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.

  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.

  • Both the left and right subtrees must also be binary search trees.

    A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

    Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer NN (\le 10001000). Then NN distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

    Output Specification:

    For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

    Sample Input:

    10
    1 2 3 4 5 6 7 8 9 0
    

    Sample Output:

    6 3 8 1 5 7 9 0 2 4

    解:这是一个完全二叉树问题,我在自己独立思考的情况下,想不到合适的方法,在看了解法之后,我震惊了:按照题意,将输入的数组由小到大排序之后就是二叉树的中序遍历情况,现在想要知道逐层遍历的情况,只需要将二叉树的下标进行中序遍历,对应即可解出每一个下标在中序遍历数组中对应的数。看代码:

    #include <iostream>
    #include <stdlib.h>
    using namespace std;
    
    const int maxlen = 10001;
    int in_index = 0;
    int level[maxlen];
    
    int compare(const void *a, const void *b){
    	return  *(int*)a - *(int*)b;
    }
    
    void in_pass(int root, int N, int array[]){
    	if(root <= N){
    		in_pass(root*2, N, array);
    		level[root] = array[in_index++];
    		in_pass(root*2+1, N, array);
    	}
    }
    
    int main(){
    	int N;
    	cin>>N;
    	int in[maxlen];
    	for(int i = 0; i < N; i++){
    		cin>>in[i];
    	}
    	qsort(in, N, sizeof(int), compare);
    //	for(int i = 0; i < N; i++){
    //		cout<<in[i]<<' ';
    //	}
    //	cout<<endl;
    	in_pass(1, N, in);
    	cout<<level[1];
    	for(int i = 2; i <= N; i++){
    		cout<<' '<<level[i];
    	}
    	return 0;
    }
    


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值