【bzoj3239】Discrete Logging BSGS

Description

Given a prime P, 2 <= P < 231, an integer B, 2 <= B < P, and an integer N, 2 <= N < P, compute the discrete logarithm of N, base B, modulo P. That is, find an integer L such that

BL == N (mod P)

Input

Read several lines of input, each containing P,B,N separated by a space,

Output

for each line print the logarithm on a separate line. If there are several, print the smallest; if there is none, print “no solution”.

The solution to this problem requires a well known result in number theory that is probably expected of you for Putnam but not ACM competitions. It is Fermat’s theorem that states

B(P-1) == 1 (mod P)
for any prime P and some other (fairly rare) numbers known as base-B pseudoprimes. A rarer subset of the base-B pseudoprimes, known as Carmichael numbers, are pseudoprimes for every base between 2 and P-1. A corollary to Fermat’s theorem is that for any m

B(-m) == B(P-1-m) (mod P) .

Sample Input

5 2 1

5 2 2

5 2 3

5 2 4

5 3 1

5 3 2

5 3 3

5 3 4

5 4 1

5 4 2

5 4 3

5 4 4

12345701 2 1111111

1111111121 65537 1111111111

Sample Output

0

1

3

2

0

3

1

2

0

no solution

no solution

1

9584351

462803587

HINT

Source


裸题。

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<map>
#include<cmath>
using namespace std;

typedef long long LL;

LL ksm(LL a,LL b,LL mod)
{
    LL ans = 1;
    while(b)
    {
        if(b & 1) ans = ((ans % mod) * (a % mod)) % mod;
        a = ((a % mod) * (a % mod)) % mod;
        b >>= 1;
    }
    return ans;
}

map<LL,LL> h;

LL BSGS(LL a,LL b,LL mod)
{
    a %= mod; b %= mod;
    if(a == 0 && b == 0) return 1;
    else if(a == 0) return -1;
    h.clear();
    LL m = ceil(sqrt(mod));
    LL ni = ksm(a,mod - m - 1,mod);
    LL t = 1;
    h[t] = 0;
    for(int i = 1;i < m;i ++)
    {
        t = (t * (a % mod)) % mod;
        if(t != 1 && !h[t]) h[t] = i;
    }
    for(int i = 0;i < m;i ++)
    {
        LL ans = h[b];
        if(b == 1 || ans)
        {
            return i * m + ans; 
        }
        b = (b * ni) % mod;
    }
    return -1;
}

int main()
{
    LL mod,a,b;
    while(~scanf("%lld%lld%lld",&mod,&a,&b))
    {
        LL ans = BSGS(a,b,mod);
        if(ans != -1) printf("%lld\n",ans);
        else puts("no solution");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值