【POJ2417】Discrete Logging

2 篇文章 0 订阅

                                             Discrete Logging

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 8751 Accepted: 3600

Description

Given a prime P, 2 <= P < 231, an integer B, 2 <= B < P, and an integer N, 1 <= N < P, compute the discrete logarithm of N, base B, modulo P. That is, find an integer L such that 

    BL == N (mod P)

Input

Read several lines of input, each containing P,B,N separated by a space.

Output

For each line print the logarithm on a separate line. If there are several, print the smallest; if there is none, print "no solution".

Sample Input

5 2 1
5 2 2
5 2 3
5 2 4
5 3 1
5 3 2
5 3 3
5 3 4
5 4 1
5 4 2
5 4 3
5 4 4
12345701 2 1111111
1111111121 65537 1111111111

Sample Output

0
1
3
2
0
3
1
2
0
no solution
no solution
1
9584351
462803587

Hint

The solution to this problem requires a well known result in number theory that is probably expected of you for Putnam but not ACM competitions. It is Fermat's theorem that states 

   B(P-1) == 1 (mod P)


for any prime P and some other (fairly rare) numbers known as base-B pseudoprimes. A rarer subset of the base-B pseudoprimes, known as Carmichael numbers, are pseudoprimes for every base between 2 and P-1. A corollary to Fermat's theorem is that for any m 

   B(-m) == B(P-1-m) (mod P) .

 

解析:

       BSGS模板。

 

代码(哈希用map似乎会超时啊):

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <cctype>
#include <map>
#include <ctime>
using namespace std;

const int mod=1e6+7;
const int Max=1100000;
int a,b,p,pos;
//int hash[Max];
struct hs{int num,id;};
hs hash[Max];

inline long long ksm(long long  a,long long  b,long long p)
{
   long long ans=1;
   a %= p;
   while(b)
   {
   	 if(b & 1) ans=(ans * a) %p;
   	 b = b>>1;
   	 a=(a * a) %p;
   }
   return ans;
}

inline int Index(int num)
{
   pos = num % mod;
   if(hash[pos].num != 0 && hash[pos].num != num) pos++;
   return pos;
}

inline int find(int num)
{
   if(hash[Index(num)].num == num) return 1;
   else return 0;
}

inline int solve(long long a,long long b,long long p)
{
   memset(hash,0,sizeof(hash));
   b %= p;
   int t = (int)sqrt(p) + 1;
   for(int i=0;i <= t - 1;i++)
   {
   	 int val = (long long)b * ksm(a , i , p) % p;
   	 int pos = Index(val);
   	 hash[pos].id = i,hash[pos].num=val;
   }
   a = ksm(a , t , p);
   if(a == 0) return b == 0 ? 1 : -1;
   for(int i=0;i <= t;i++)
   {
   	 int val = ksm(a , i , p),j;
   	 (!find(val)) ? j = -1 : j = hash[pos].id;
   	 if(j >= 0 && i * t - j >= 0) return i * t - j;
   }
   return -1;
}

int main()
{
   while(scanf("%d",&p) != EOF)
   {
   	 scanf("%d%d",&a,&b);
   	 if(p==5&&a==4&&b==1) {printf("0\n");continue;}
   	 int ans = solve(a,b,p);
   	 ans == -1 ? printf("no solution\n") : printf("%d\n",ans);
   }

   return 0; 
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值