迷宫问题(BFS回溯)

20 篇文章 0 订阅
8 篇文章 0 订阅

                                                                          迷宫问题

題目鏈接 : http://acm.sdtbu.edu.cn/vjudge/contest/view.action?cid=2181#problem/J

Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

定义一个二维数组: 

int maze[5][5] = {

 0, 1, 0, 0, 0,

 0, 1, 0, 1, 0,

 0, 0, 0, 0, 0,

 0, 1, 1, 1, 0,

 0, 0, 0, 1, 0,

};


它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
#include <iostream>
#include <algorithm>
#include <cstdlib>
#include <cmath>
#include <cstring>
#include <cstdio>
#include <queue>
#include <stack>
using namespace std;

struct A
{
    int x,y,time;
    int per,my;
}w[5000];
int n=5,e=1;
int a[6][6],vis[6][6];
int cc[4][2]={0,1,0,-1,1,0,-1,0};
queue<A> q;
int BFS()
{
    A now;
    now.x=0;
    now.y=0;
    now.time=0;
    now.per=-1;
    now.my=1;
    q.push(now);
    w[e++]=now;
    while(!q.empty())
    {
        now=q.front();
        q.pop();
        if(now.x==4&&now.y==4)
        {
            return now.my;
        }
        for(int i=0;i<4;i++)
        {
            A t;
            t.x=now.x+cc[i][0];
            t.y=now.y+cc[i][1];
            t.time=now.time+1;
            t.per=now.my;
            t.my=e;
            if(t.x>=0&&t.x<n&&t.y>=0&&t.y<n)
            if(vis[t.x][t.y]==0&&a[t.x][t.y]==0)
            {
                w[e++]=t;
                q.push(t);
            }
        }
    }
    return -1;
}
int main()
{
    for(int i=0;i<n;i++)
        for(int j=0;j<n;j++)
          cin>>a[i][j];
    int t=BFS();
    stack<A> st;
    while(1)
    {
        st.push(w[t]);
        t=w[t].per;
        if(t==-1)
          break;
    }
    while(!st.empty())
    {
        cout<<"("<<st.top().x<<", "<<st.top().y<<")"<<endl;
        st.pop();
    }
    return 0;
}

 

  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值