原题链接:http://www.lydsy.com/JudgeOnline/problem.php?id=1079
着色方案
Description
有n个木块排成一行,从左到右依次编号为1~n。你有k种颜色的油漆,其中第i种颜色的油漆足够涂ci个木块。
所有油漆刚好足够涂满所有木块,即c1+c2+…+ck=n。相邻两个木块涂相同色显得很难看,所以你希望统计任意两
个相邻木块颜色不同的着色方案。
Input
第一行为一个正整数k,第二行包含k个整数c1, c2, … , ck。
Output
输出一个整数,即方案总数模1,000,000,007的结果。
Sample Input
3
1 2 3
Sample Output
10
HINT
100%的数据满足:1 <= k <= 15, 1 <= ci <= 5
题解
大佬难题选讲了这道题,初步了解一下高维dp。。。
我们注意到
ci⩽5
c
i
⩽
5
,那么就有一种非常暴力的做法,我们记录可以用5次的颜色有多少,可以用4次的颜色有多少。。。这样我们就能得到状态转移方程:
具体来讲,当我们用了一种可以用5次的颜色时,可以用5次的颜色就少了一种,可以用4次的颜色多了一种,然后这个方案数还要乘以可以用5次的颜色的个数。其他情况以此类推。。。
但是,我们还没有考虑重复的情况,所以我们要再开一维记录上一次用的颜色本来可以用几次,在最后乘以系数的时候要减掉被重复使用的情况。
代码
#include<bits/stdc++.h>
#define ll long long
#define r dp[last][a][b][c][d][e]
using namespace std;
const int mod=1e9+7;
int k,tot[20];
ll dp[16][16][16][16][16][16];
void in()
{
scanf("%d",&k);
int x;
for(int i=1;i<=k;++i)
scanf("%d",&x),tot[x]++;
}
ll dfs(int last,int a,int b,int c,int d,int e)
{
if(last&&r)return r;
if(a)r+=dfs(5,a-1,b+1,c,d,e)*a;
if(b)r+=dfs(4,a,b-1,c+1,d,e)*(b-(last==5));
if(c)r+=dfs(3,a,b,c-1,d+1,e)*(c-(last==4));
if(d)r+=dfs(2,a,b,c,d-1,e+1)*(d-(last==3));
if(e)r+=dfs(1,a,b,c,d,e-1)*(e-(last==2));
return r=r%mod;
}
void ac()
{
dp[1][0][0][0][0][0]=1;
printf("%lld",dfs(0,tot[5],tot[4],tot[3],tot[2],tot[1]));
}
int main()
{
in();ac();
return 0;
}