暂无链接
洞穴辐射
[问题描述]
在火星表面着陆后,科学家发现了一个由隧道相连的洞穴系统。于是,他们开始使用遥控机器人帮助研究,它在每两个洞穴之间可以找到一条航线。洞穴中因微弱爆炸产生辐射,科学家们在每个洞穴内安装传感器来监测辐射水平。对于机器人的每次移动,他们想知道机器人在移动过程中要面对的最大辐射水平。因此,他们要求你写一个程序来解决他们的问题。
[输入格式]
笫一行为一个整数 n ( l ≤ n ≤ 100000 ) n(l \le n \le 100000) n(l≤n≤100000)表示洞穴的数量。
接下来 n − 1 n-1 n−1行描述隧道,每行包含两个整数 A i , B i ( l ≤ A i , B i ≤ n ) A_i,B_i(l \le A_i,B_i \le n) Ai,Bi(l≤Ai,Bi≤n),表示相应的洞穴被隧道相连。
下一行有一个整数 q ( q ≤ 100000 ) q(q \le 100000) q(q≤100000)表示指令数。
接下来 q q q行描述指令,均以 G G G或 I I I为开头:
(1) G u v G\ u\ v G u v:表示这是一个査询,询问当机器人从洞穴 u u u移动到洞穴 v v v所受到的最大辐射值为多少;
(2) I u v I\ u\ v I u v:表示洞穴 u u u处发生了微弱爆炸,该处的辐射值增加了 v ( 0 ≤ v ≤ 10000 ) v(0 \le v \le 10000) v(0≤v≤10000),默认初始时辐射值均为0。
[输出格式]
对于每一个査询输出一行,表示最大辐射水平。
[输入样例]
4
1 2
2 3
2 4
6
I 1 1
G 1 1
G 3 4
I 2 3
G 1 1
G 3 4
[输出样例]
1
0
1
3
[时间和空间限制]
时间限制为3秒,空间限制为64MB。
题解
打板
代码
#include<bits/stdc++.h>
#define ls son[v][0]
#define rs son[v][1]
using namespace std;
const int M=1e5+5;
int son[M][2],dad[M],mx[M],val[M],n,q;
bool rev[M];
bool notroot(int v){return son[dad[v]][0]==v||son[dad[v]][1]==v;}
void up(int v){mx[v]=max(val[v],max(mx[ls],mx[rs]));}
void turn(int v){swap(ls,rs);rev[v]^=1;}
void down(int v){if(!rev[v])return;if(ls)turn(ls);if(rs)turn(rs);rev[v]=0;}
void push(int v){if(notroot(v))push(dad[v]);down(v);}
void spin(int v)
{
int f=dad[v],ff=dad[f],k=son[f][1]==v,w=son[v][!k];
if(notroot(f))son[ff][son[ff][1]==f]=v;
son[v][!k]=f;son[f][k]=w;
if(w)dad[w]=f;
dad[f]=v;dad[v]=ff;
up(f);up(v);
}
void splay(int v)
{
push(v);
int f,ff;
while(notroot(v))
{
f=dad[v];ff=dad[f];
if(notroot(f))spin((son[f][0]==v)^(son[ff][0]==f)?v:f);
spin(v);
}
}
void access(int v){for(int f=0;v;v=dad[f=v])splay(v),rs=f,up(v);}
void beroot(int v){access(v);splay(v);turn(v);}
void split(int x,int y){beroot(x);access(y);splay(y);}
void link(int x,int y){beroot(x);dad[x]=y;}
void in()
{
int a,b;
scanf("%d",&n);
for(int i=1;i<n;++i)
scanf("%d%d",&a,&b),link(a,b);
}
void ac()
{
char ch[10];
int a,b;
scanf("%d",&q);
for(int i=1;i<=q;++i)
{
scanf("%s%d%d",ch,&a,&b);
if(ch[0]=='G')split(a,b),printf("%d\n",mx[b]);
else splay(a),val[a]+=b,up(a);
}
}
int main()
{
in();ac();
return 0;
}