POJ 3041 Asteroids(二分图最大匹配)

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).


题目大意:
        英语实在太弱了,大概的意思就是在N*N网格中有一些小行星,有一种武器可以一次性消除一行或者一列的行星,但是这种武器实在是太贵了,所以使用次数应该尽量的少,问最少使用多少次可以消除所有的行星。
解题思路:
        因为题目上给定的是坐标,不太容易看出来,把坐标转换成Hint里的图的形式,就可以看出此题可以用二分图的知识解决,因为行数和列数相等,所以吧行号和列号作为两个点集,构成二分图,用行号来匹配列号,小行星所在的行列位置代表此行此列在二分图中有一条边,每次使用武器可以消除一行或者一列,也就是说每次使用武器可以去除与某个点相连的所有边,其实也就是求最大匹配数(好好想想,这玩意不太好解释。。。

#include <iostream>
#include <fstream>
#include <cstdio>
#include <cmath>
#include <map>
#include <set>
#include <bitset>
#include <ctime>
#include <cstring>
#include <algorithm>
#include <stack>
#include <queue>
#include <vector>
#include <list>

#define STD_REOPEN() freopen("../in.in","r",stdin)
#define STREAM_REOPEN fstream cin("../in.in")
#define INF 0x3f3f3f3f
#define _INF 63
#define eps 1e-8
#define MAX_V 100010
#define MAX_P 510
#define MAX_E 10010
#define MAX 32000
#define MOD_P 3221225473
#define MOD 9901

using namespace std;

bool s[MAX_P][MAX_P];
bool vis[MAX_P];
int link[MAX_P];
int n,k;

bool dfs(int x)
{
	for(int i=1;i<=n;i++)
	{
		if(s[x][i]&&!vis[i])
		{
			vis[i]=true;
			if(link[i]==-1||dfs(link[i]))
			{
				link[i]=x;
				return true;
			}
		}
	}
	return false;
}

int main()
{
	//STD_REOPEN();
	while(~scanf("%d %d",&n,&k))
	{
		memset(link,-1,sizeof(link));
		memset(s,0,sizeof(s));
		int u,v;
		for(int i=0;i<k;i++)
		{
			scanf("%d %d",&u,&v);
			s[u][v]=true;
		}
		int ans=0;
		for(int i=1;i<=n;i++)
		{
			memset(vis,0,sizeof(vis));
			if(dfs(i))
				ans++;
		}
		printf("%d\n",ans);
	}

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值