Problem C. Dynamic Graph Matching
Time Limit: 8000/4000 MS (Java/Others) Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 1402 Accepted Submission(s): 581
Problem Description
In the mathematical discipline of graph theory, a matching in a graph is a set of edges without common vertices.
You are given an undirected graph with n vertices, labeled by 1,2,...,n. Initially the graph has no edges.
There are 2 kinds of operations :
+ u v, add an edge (u,v) into the graph, multiple edges between same pair of vertices are allowed.
- u v, remove an edge (u,v), it is guaranteed that there are at least one such edge in the graph.
Your task is to compute the number of matchings with exactly k edges after each operation for k=1,2,3,...,n2. Note that multiple edges between same pair of vertices are considered different.
Input
The first line of the input contains an integer T(1≤T≤10), denoting the number of test cases.
In each test case, there are 2 integers n,m(2≤n≤10,nmod2=0,1≤m≤30000), denoting the number of vertices and operations.
For the next m lines, each line describes an operation, and it is guaranteed that 1≤u<v≤n.
Output
For each operation, print a single line containing n2 integers, denoting the answer for k=1,2,3,...,n2. Since the answer may be very large, please print the answer modulo 109+7.
Sample Input
1
4 8
+ 1 2
+ 3 4
+ 1 3
+ 2 4
- 1 2
- 3 4
+ 1 2
+ 3 4
Sample Output
1 0
2 1
3 1
4 2
3 1
2 1
3 1
4 2
Source
2018 Multi-University Training Contest 3
Recommend
chendu
【思路】
把每个K(0 <= K <= N/2)匹配数用一个0 <= S < (1 << N)的数表示,即一个点集,每次添加边的操作得到的K匹配数可以由上一个(包含该边的)K匹配数和(不包含该边的)K - 1匹配数转移得到,每次删除边的操作得到的K匹配数可以由上一个(不包含该边的)K匹配数和(包含该边的)K + 1匹配数得到。注意最后答案还要确保为正,故加1e9 + 7取模。
【代码】
//******************************************************************************
// File Name: C.cpp
// Author: Shili_Xu
// E-Mail: shili_xu@qq.com
// Created Time: 2018年07月31日 星期二 21时43分44秒
//******************************************************************************
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
typedef long long ll;
const int MAXN = 1 << 10, MOD = 1e9 + 7;
int t, n, m;
int cnt[MAXN];
ll f[MAXN], ans[15];
int main()
{
for (int i = 0; i < MAXN; i++)
cnt[i] = __builtin_popcount(i);
scanf("%d", &t);
while (t--) {
scanf("%d %d", &n, &m);
int all = (1 << n);
memset(f, 0, sizeof(f));
f[0] = 1;
while (m--) {
char mes[2];
int u, v;
scanf("%s %d %d", mes, &u, &v);
int paigu = (1 << (u - 1)) | (1 << (v - 1));
if (mes[0] == '+') {
for (int i = 0; i < all; i++) {
if (!(i & paigu))
f[i ^ paigu] = (f[i ^ paigu] + f[i]) % MOD;
}
}
else {
for (int i = 0; i < all; i++) {
if (!(i & paigu))
f[i ^ paigu] = (f[i ^ paigu] - f[i]) % MOD;
}
}
memset(ans, 0, sizeof(ans));
for (int i = 0; i < all; i++) {
ans[cnt[i]] = (ans[cnt[i]] + f[i]) % MOD;
}
for (int i = 2; i <= n; i += 2)
printf("%lld%c", (ans[i] % MOD + MOD) % MOD, " \n"[i == n]);
}
}
return 0;
}