HDU 6321 Dynamic Graph Matching(状压DP)

Problem C. Dynamic Graph Matching

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 1402    Accepted Submission(s): 581


 

Problem Description

In the mathematical discipline of graph theory, a matching in a graph is a set of edges without common vertices.
You are given an undirected graph with n vertices, labeled by 1,2,...,n. Initially the graph has no edges.
There are 2 kinds of operations :
+ u v, add an edge (u,v) into the graph, multiple edges between same pair of vertices are allowed.
- u v, remove an edge (u,v), it is guaranteed that there are at least one such edge in the graph.
Your task is to compute the number of matchings with exactly k edges after each operation for k=1,2,3,...,n2. Note that multiple edges between same pair of vertices are considered different.

 

 

Input

The first line of the input contains an integer T(1≤T≤10), denoting the number of test cases.
In each test case, there are 2 integers n,m(2≤n≤10,nmod2=0,1≤m≤30000), denoting the number of vertices and operations.
For the next m lines, each line describes an operation, and it is guaranteed that 1≤u<v≤n.

 

 

Output

For each operation, print a single line containing n2 integers, denoting the answer for k=1,2,3,...,n2. Since the answer may be very large, please print the answer modulo 109+7.

 

 

Sample Input

 

1

4 8

+ 1 2

+ 3 4

+ 1 3

+ 2 4

- 1 2

- 3 4

+ 1 2

+ 3 4

 

 

Sample Output

 

1 0

2 1

3 1

4 2

3 1

2 1

3 1

4 2

 

 

Source

2018 Multi-University Training Contest 3

 

 

Recommend

chendu

 

【思路】

把每个K(0 <= K <= N/2)匹配数用一个0 <= S < (1 << N)的数表示,即一个点集,每次添加边的操作得到的K匹配数可以由上一个(包含该边的)K匹配数和(不包含该边的)K - 1匹配数转移得到,每次删除边的操作得到的K匹配数可以由上一个(不包含该边的)K匹配数和(包含该边的)K + 1匹配数得到。注意最后答案还要确保为正,故加1e9 + 7取模。

 

【代码】

//******************************************************************************
// File Name: C.cpp
// Author: Shili_Xu
// E-Mail: shili_xu@qq.com
// Created Time: 2018年07月31日 星期二 21时43分44秒
//******************************************************************************

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
typedef long long ll;

const int MAXN = 1 << 10, MOD = 1e9 + 7;

int t, n, m;
int cnt[MAXN];
ll f[MAXN], ans[15];

int main()
{
	for (int i = 0; i < MAXN; i++)
		cnt[i] = __builtin_popcount(i);
	scanf("%d", &t);
	while (t--) {
		scanf("%d %d", &n, &m);
		int all = (1 << n);
		memset(f, 0, sizeof(f));
		f[0] = 1;
		while (m--) {
			char mes[2];
			int u, v;
			scanf("%s %d %d", mes, &u, &v);
			int paigu = (1 << (u - 1)) | (1 << (v - 1));
			if (mes[0] == '+') {
				for (int i = 0; i < all; i++) {
					if (!(i & paigu))
						f[i ^ paigu] = (f[i ^ paigu] + f[i]) % MOD;
				}
			}
			else {
				for (int i = 0; i < all; i++) {
					if (!(i & paigu))
						f[i ^ paigu] = (f[i ^ paigu] - f[i]) % MOD;
				}
			}
			memset(ans, 0, sizeof(ans));
			for (int i = 0; i < all; i++) {
				ans[cnt[i]] = (ans[cnt[i]] + f[i]) % MOD;
			}
			for (int i = 2; i <= n; i += 2)
				printf("%lld%c", (ans[i] % MOD + MOD) % MOD, " \n"[i == n]);
		}
	}
	return 0;
}

 

内容概要:本文详细介绍了如何利用Simulink进行自动代码生成,在STM32平台上实现带57次谐波抑制功能的霍尔场定向控制(FOC)。首先,文章讲解了所需的软件环境准备,包括MATLAB/Simulink及其硬件支持包的安装。接着,阐述了构建永磁同步电机(PMSM)霍尔FOC控制模型的具体步骤,涵盖电机模型、坐标变换模块(如Clark和Park变换)、PI调节器、SVPWM模块以及用于抑制特定谐波的陷波器的设计。随后,描述了硬件目标配置、代码生成过程中的注意事项,以及生成后的C代码结构。此外,还讨论了霍尔传感器的位置估算、谐波补偿器的实现细节、ADC配置技巧、PWM死区时间和换相逻辑的优化。最后,分享了一些实用的工程集成经验,并推荐了几篇有助于深入了解相关技术和优化控制效果的研究论文。 适合人群:从事电机控制系统开发的技术人员,尤其是那些希望掌握基于Simulink的自动代码生成技术,以提高开发效率和控制精度的专业人士。 使用场景及目标:适用于需要精确控制永磁同步电机的应用场合,特别是在面对高次谐波干扰导致的电流波形失真问题时。通过采用文中提供的解决方案,可以显著改善系统的稳定性和性能,降低噪声水平,提升用户体验。 其他说明:文中不仅提供了详细的理论解释和技术指导,还包括了许多实践经验教训,如霍尔传感器处理、谐波抑制策略的选择、代码生成配置等方面的实际案例。这对于初学者来说是非常宝贵的参考资料。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值