HDOJ1130 卡特兰数裸题

How Many Trees?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4004    Accepted Submission(s): 2265


Problem Description
A binary search tree is a binary tree with root k such that any node v reachable from its left has label (v) <label (k) and any node w reachable from its right has label (w) > label (k). It is a search structure which can find a node with label x in O(n log n) average time, where n is the size of the tree (number of vertices). 

Given a number n, can you tell how many different binary search trees may be constructed with a set of numbers of size n such that each element of the set will be associated to the label of exactly one node in a binary search tree? 
 

Input
The input will contain a number 1 <= i <= 100 per line representing the number of elements of the set.
 

Output
You have to print a line in the output for each entry with the answer to the previous question.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2 5
 

Source
UVA
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:   1131  1134  1133  2067  1267 

题意跟HDOJ1023没什么本质区别。。
一个讲的很好的博客链接:卡特兰数介绍

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

const int maxn = 105;
int a[maxn][maxn];
int i,j,k,n;

void chart(){
    int i,j,len;
    a[1][0] = a[1][1] = 1;
    a[2][0] = 1; a[2][1] = 2;
    len = 1;

    int tmp,c;
    for (i=3; i<=100; i++) {
        c = 0;
        for (j=1; j<=len; j++) {
            tmp = a[i-1][j]*(4*i-2) + c;
            c = tmp/10;
            a[i][j] = tmp%10;
        }

        while (c) {
            a[i][++len] = c%10;
            c /=10;
        }

        for (j=len; j>0; j--) {
            tmp = a[i][j] + c*10;
            a[i][j] = tmp/(i+1);
            c = tmp%(i+1);
        }

        while (!a[i][len]) len--;
        a[i][0] = len;
    }
}

int main(){
    chart();
    while (scanf("%d",&n)!=EOF){
        k = a[n][0];
        for (i=k; i>0; i--) printf("%d",a[n][i]);
        printf("\n");
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值