HDU 4006-The kth great number

The kth great number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 12416    Accepted Submission(s): 4868


题目链接:点击打开链接


Problem Description
Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
 

Input
There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number. 
 

Output
The output consists of one integer representing the largest number of islands that all lie on one line. 

Sample Input
8 3
I 1
I 2
I 3
Q
I 5
Q
I 4
Q
 


Sample Output
1
2
3


Hint
Xiao  Ming  won't  ask  Xiao  Bao  the  kth  great  number  when  the  number  of  the  written number is smaller than k. (1=<k<=n<=1000000).



题意:
有 n 行数据,k 代表的是第 k 大值,如果输入 I 就输入一个数,如果输入 Q 就输出之前输入的一系列数中的第 k 大的数。


分析:
用优先队列,但得考虑数据较大会导致时间超限的问题,所以用一个优先队列从小到大的顺序,如果 push 进去的元素大于 k 个,则让队首元素 pop ,这样就可以一直保持队首元素正好是第 k 大的值,这里我给出了两个代码,分别是不同的优先队列定义的方式。



代码一:
#include <iostream>
#include <stdio.h>
#include <queue>
#include <cstring>
#include <string>
using namespace std;

struct cmp1{
    bool operator () (int x,int y)
    {
        return x>y;
    }
};
int main()
{
    int m,n,k;
    char s;
    while(~scanf("%d %d",&n,&k))
    {
       //priority_queue<int,vector<int>,greater<int> >q;//优先队列,按由小到大顺序
        priority_queue<cmp1,vector<int>,cmp1>q;
        while(n--)
        {
            getchar();
            scanf("%c",&s);
            if(s=='I')
            {
                scanf("%d",&m);
                q.push(m);
                if(q.size()>k)
                    q.pop();
            }
            else
                printf("%d\n",q.top());
        }
    }
    return 0;
}

代码二:
#include <iostream>
#include <stdio.h>
#include <queue>
#include <cstring>
#include <string>
using namespace std;

/*struct cmp1{
    bool operator () (int x,int y)
    {
        return x>y;
    }
};*/
int main()
{
    int m,n,k;
    char s;
    while(~scanf("%d %d",&n,&k))
    {
       priority_queue<int,vector<int>,greater<int> >q;//优先队列,按由小到大顺序
        //priority_queue<cmp1,vector<int>,cmp1>q;
        while(n--)
        {
            getchar();
            scanf("%c",&s);
            if(s=='I')
            {
                scanf("%d",&m);
                q.push(m);
                if(q.size()>k)
                    q.pop();
            }
            else
                printf("%d\n",q.top());
        }
    }
    return 0;
}


 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值