hdoj 3351 Seinfeld(括号配对)



http://acm.hdu.edu.cn/showproblem.php?pid=3351

Seinfeld

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1370    Accepted Submission(s): 676


Problem Description
I’m out of stories. For years I’ve been writing stories, some rather silly, just to make simple problems look difficult and complex problems look easy. But, alas, not for this one.
You’re given a non empty string made in its entirety from opening and closing braces. Your task is to find the minimum number of “operations” needed to make the string stable. The definition for being stable is as follows:
1. An empty string is stable.
2. If S is stable, then {S} is also stable.
3. If S and T are both stable, then ST (the concatenation of the two) is also stable.
All of these strings are stable: {}, {}{}, and {{}{}}; But none of these: }{, {{}{, nor {}{.
The only operation allowed on the string is to replace an opening brace with a closing brace, or visa-versa.
 


Input
Your program will be tested on one or more data sets. Each data set is described on a single line. The line is a non-empty string of opening and closing braces and nothing else. No string has more than 2000 braces. All sequences are of even length.
The last line of the input is made of one or more ’-’ (minus signs.)

 


Output
For each test case, print the following line:
k. N
Where k is the test case number (starting at one,) and N is the minimum number of operations needed to convert the given string into a balanced one.
Note: There is a blank space before N.
 


Sample Input
  
  
}{ {}{}{} {{{} ---
 


Sample Output
  
  
1. 2 2. 0 3. 1
 

用到栈,top为标准,当最后top=0时,栈中无元素,输出0,(还有就是当输入为空时 (emtpy)是输出也为0。注意emtpy是空字符不是空格),当top!=0时,判断需要做多少次变换,两个为一组判断,如果为 '}'和'{',则变化两次,如果为'{','{'或'}','}',则变化一次。

#include<stdio.h>
#include<string.h>
int main()
{
	char a[2100],s[2100];
	int n,i,j,k,top,t=1,sum;
	while(gets(a))
	{
		if(a[0]=='-') break;
		if(!a[0]/*||a[0]==' '*/) 
		{//当a为 empty,不明白empty是空字符还是空格,所以都包含了 
		   //后来又试了一下,empty表示的是空字符串,不是空格 
		   printf("%d. 0\n",t++);
		   continue;
	    } 
	    memset(s,'\0',sizeof(s));
	    n=strlen(a);
	    for(i=0,top=0;i<n;i++)
	    {
	    	if(a[i]=='{')
	    	{
	    		top+=1;
	    		s[top]='{';
	    		continue;
	    	}
	    	if(a[i]=='}'&&s[top]=='{')
	    	{
   		        s[top]='\0';
   		        top-=1;
   		    }
   		    else
   		    {
   		    	top+=1;
   		    	s[top]='}';
   		    }
   		   // printf("%d %c %d#\n",top,a[i],i);
   		}
   		//printf("%c %c %d\n",s[1],s[2],top);
   		
   		if(top==0)
   		printf("%d. 0\n",t++);
   		else
   		{
   			for(i=1,sum=0;i<=top;i+=2)
   			if(s[i]=='}'&&s[i+1]=='{')
   			sum+=2;
   			else if(s[i]=='{'&&s[i]=='{'||s[i]=='}'&&s[i]=='}')
   			sum+=1;
   			
   			printf("%d. %d\n",t++,sum);
   		}
	 	
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值