hdoj 2438 Turn the corner

Turn the corner

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1906    Accepted Submission(s): 726


Problem Description
Mr. West bought a new car! So he is travelling around the city.

One day he comes to a vertical corner. The street he is currently in has a width x, the street he wants to turn to has a width y. The car has a length l and a width d.

Can Mr. West go across the corner?

 


Input
Every line has four real numbers, x, y, l and w.
Proceed to the end of file.
 


Output
If he can go across the corner, print "yes". Print "no" otherwise.
 


Sample Input
  
  
10 6 13.5 4 10 6 14.5 4
 


Sample Output
  
  
yes no

#include<stdio.h>
#include<string.h>
#include<math.h>
#define pi (3.14/2)
#define add 0.0001
int main()
{
    double x,y,L,D,i;
    bool judge;
    while(scanf("%lf %lf %lf %lf",&x,&y,&L,&D)!=EOF)
    {
            for(i=0,judge=true;i<=pi;i+=add)
            if(L*cos(i)-x*cos(i)/sin(i)+D/sin(i)>=y)
            {
                   judge=false;
                   break;
            }
            if(judge)
            printf("yes\n");
            else
            printf("no\n");
            
    }
    return 0;
}         


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值