hdoj 2438 Turn the corner (三分搜索+计算几何)

Turn the corner

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3140    Accepted Submission(s): 1272


Problem Description
Mr. West bought a new car! So he is travelling around the city.

One day he comes to a vertical corner. The street he is currently in has a width x, the street he wants to turn to has a width y. The car has a length l and a width d.

Can Mr. West go across the corner?

 

Input
Every line has four real numbers, x, y, l and w.
Proceed to the end of file.
 

Output
If he can go across the corner, print "yes". Print "no" otherwise.
 

Sample Input
  
  
10 6 13.5 4 10 6 14.5 4
 

Sample Output
  
  
yes no

题意:一辆宽长已知的车要过宽度分别为 x y 的马路的拐角处,问能否通过。

思路:假设车尾恰好在马路的临界处,然后看车头能否通过详解链接

sinta 角(90-->0),不断减小时,H先从小变大 再变小,所以是一个凸性函数,当最大H<y时 车就能通过,求凸性函数最值三分搜索

code

//三角函数用π计算
#include <iostream>
#include<cstdio>
#include<cmath>
using namespace std;
#define PI 3.14159265358979
double x,y,l,d;
double high(double sinta)
{
    double s=l*cos(sinta)+d*sin(sinta)-x;
    double h=s*tan(sinta)+d*cos(sinta);
    return h;
}
int main()
{
    while(~scanf("%lf%lf%lf%lf",&x,&y,&l,&d))
    {
        double l,r,mid,midmid;
        l=0.0;r=acos(-1.0)/2;
        while(r-l>=1e-10)
        {
            mid=(l+r)/2;
            midmid=(mid+r)/2;
            if(high(mid)>high(midmid))
                r=midmid;
            else
                l=mid;
        }
        if(high(mid)<=y)
            printf("yes\n");
        else
            printf("no\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值