HDOJ 3999 The order of a Tree(二叉排序树)



http://acm.hdu.edu.cn/showproblem.php?pid=3999

The order of a Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1265    Accepted Submission(s): 645


Problem Description
As we know,the shape of a binary search tree is greatly related to the order of keys we insert. To be precisely:
1.  insert a key k to a empty tree, then the tree become a tree with
only one node;
2.  insert a key k to a nonempty tree, if k is less than the root ,insert
it to the left sub-tree;else insert k to the right sub-tree.
We call the order of keys we insert “the order of a tree”,your task is,given a oder of a tree, find the order of a tree with the least lexicographic order that generate the same tree.Two trees are the same if and only if they have the same shape.
 


Input
There are multiple test cases in an input file. The first line of each testcase is an integer n(n <= 100,000),represent the number of nodes.The second line has n intergers,k1 to kn,represent the order of a tree.To make if more simple, k1 to kn is a sequence of 1 to n.
 


Output
One line with n intergers, which are the order of a tree that generate the same tree with the least lexicographic.
 


Sample Input
  
  
4 1 3 4 2
 


Sample Output
  
  
1 3 2 4


//题意:给出一个建立二叉排序树时各节点的顺序,找到二叉排序树字典序最小的顺序
#include<stdio.h>   //二叉排序树(Binary Sort Tree)或二叉查找树(Binary Search Tree)或二叉搜索树
#include<string.h>
#include<malloc.h>
struct Node
{
	int date;
	struct Node *lchild,*rchild;
};
int j;
void CreatBintree(struct Node *root,int *num,int n)//建立二叉树排序树 
{
	int i;
	struct Node *p,*head;
	for(i=1;i<n;i++)
	{
	    head=root;
		p=(struct Node *)malloc(sizeof(struct Node));
		p->date=num[i];
		p->lchild=NULL;
		p->rchild=NULL;
		 
		while(1)
		{//将节点插入二叉排序树 
			if(p->date<head->date&&!(head->lchild))
			{//如果该节点小于当前根节点并且左子树为空,将该节点接到当前根节点的左子树,并跳出循环 
				head->lchild=p;
				break;
			}
			else if(p->date>=head->date&&!(head->rchild))
			{//如果该节点大于等于当前根节点并且右子树为空,将该节点接到当前根节点的右子树,并跳出循环 
				head->rchild=p;
				break;
			}
			
			if(p->date<head->date&&head->lchild)
			{//如果该节点小于当前根节点并且左子树不为空,当前根节点变为左子树,继续循环  
				head=head->lchild;
				continue;
			}
			else if(p->date>=head->date&&head->rchild)
			{//如果该节点大于等于当前根节点并且右子树不为空,当前根节点变为右子树,继续循环 
				head=head->rchild;
				continue;
			}
		}
    }
}
void Ergodic(struct Node *root,int *m)
{
	m[j++]=root->date;
	if(root->lchild) Ergodic(root->lchild,m);
	if(root->rchild) Ergodic(root->rchild,m);
}
int main()
{
	int n,i;
	while(~scanf("%d",&n))
	{
		int *num=(int *)malloc(sizeof(int)*n);
		for(i=0;i<n;i++)
		scanf("%d",&num[i]);
		//-----建立根节点-----//
		struct Node *root;
		root=(struct Node *)malloc(sizeof(struct Node));
		root->date=num[0];
		root->lchild=NULL;
		root->rchild=NULL; 
		//--------------------// 
		CreatBintree(root,num,n);//建立二叉排序树 
		
		int *m=(int *)malloc(sizeof(int)*n);
		memset(m,0,sizeof(m));
		j=0; 
		Ergodic(root,m);//遍历二叉排序树找到字典序最小的顺序 ,保存到m数组中 
		for(i=0;i<j;i++)
		{
			printf("%d",m[i]);
			if(i!=j-1) printf(" ");
			else printf("\n");
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值